Bug 811313 - systemd-tmpfiles-clean.service and systemd-tmpfiles-setup.service fail to run
systemd-tmpfiles-clean.service and systemd-tmpfiles-setup.service fail to run
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 13:11 EDT by cblaauw
Modified: 2012-04-13 13:52 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-13 13:52:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cblaauw 2012-04-10 13:11:23 EDT
Description of problem:

systemctl gives the following output:

Version-Release number of selected component (if applicable):
systemd-tmpfiles-clean.service                loaded failed failed        Cleanup of Temporary Directories
systemd-tmpfiles-setup.service                loaded failed failed        Recreate Volatile Files and Directories

How reproducible:
always
Steps to Reproduce:
1.boot
2.enter 'sysetmctl' inside a shell
3.
  
Actual results:
two services failed to run

Expected results:

everything runs without failure

Additional info:
systemd-44-4.fc17.x86_64
Comment 1 Lennart Poettering 2012-04-11 08:55:20 EDT
Please check "systemd-journalctl" and look for any output related to systemd-tmpfiles, which might explain this.
Comment 2 cblaauw 2012-04-11 16:24:35 EDT
Systemd-journalctl does nat show any info related to the tmpfiles services. If you need it, I can attach the output.

Thanks,

Carsten
Comment 3 cblaauw 2012-04-12 13:05:56 EDT
Do I need those services, if I have a tmpfs mounted at /tmp?
Comment 4 Michal Schmidt 2012-04-13 06:30:11 EDT
Yes, you need them. They handle more than just /tmp. For instance, they create some service directories under /run.

What does this command show?:
systemctl status systemd-tmpfiles-clean.service systemd-tmpfiles-setup.service
Comment 5 cblaauw 2012-04-13 11:58:58 EDT
 systemctl status systemd-tmpfiles-clean.service systemd-tmpfiles-setup.service
systemd-tmpfiles-clean.service - Cleanup of Temporary Directories
	  Loaded: loaded (/usr/lib/systemd/system/systemd-tmpfiles-clean.service; static)
	  Active: failed (Result: exit-code) since Thu, 12 Apr 2012 22:01:26 +0200; 19h ago
	 Process: 4623 ExecStart=/usr/bin/systemd-tmpfiles --clean (code=exited, status=1/FAILURE)
	  CGroup: name=systemd:/system/systemd-tmpfiles-clean.service

Apr 12 22:01:26 m7 systemd-tmpfile[4623]: Successfully loaded SELinux database in 16ms 222us, size on heap is 529K.
Apr 12 22:01:26 m7 systemd-tmpfile[4623]: [/etc/tmpfiles.d/radvd.conf:1] Unknown user 'radvd'.

systemd-tmpfiles-setup.service - Recreate Volatile Files and Directories
	  Loaded: loaded (/usr/lib/systemd/system/systemd-tmpfiles-setup.service; static)
	  Active: failed (Result: exit-code) since Thu, 12 Apr 2012 19:03:06 +0200; 22h ago
	 Process: 644 ExecStart=/usr/bin/systemd-tmpfiles --create --remove (code=exited, status=1/FAILURE)
	  CGroup: name=systemd:/system/systemd-tmpfiles-setup.service

Apr 12 19:03:06 m7 systemd-tmpfile[644]: Successfully loaded SELinux database in 10ms 385us, size on heap is 529K.
Apr 12 19:03:06 m7 systemd-tmpfile[644]: [/etc/tmpfiles.d/radvd.conf:1] Unknown user 'radvd'.
Comment 6 cblaauw 2012-04-13 12:22:13 EDT
Apprantlx todays's updates fixed the problem for me. Maybe it was the update of radvd?
Comment 7 Michal Schmidt 2012-04-13 13:52:53 EDT
That's likely. The %pre scriptlet of the radvd package run during the update created the 'radvd' user.

Note You need to log in before you can comment on or make changes to this bug.