Bug 811315 - pkcsslotd runs as initrc_t
pkcsslotd runs as initrc_t
Status: CLOSED DUPLICATE of bug 855834
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks: 832330
  Show dependency treegraph
 
Reported: 2012-04-10 13:21 EDT by Milos Malik
Modified: 2013-01-03 10:18 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-03 10:18:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2012-04-10 13:21:10 EDT
Description of problem:


Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.7.19-145.el6.noarch
selinux-policy-doc-3.7.19-145.el6.noarch
selinux-policy-mls-3.7.19-145.el6.noarch
selinux-policy-3.7.19-145.el6.noarch
selinux-policy-minimum-3.7.19-145.el6.noarch
opencryptoki-2.4-2.el6.x86_64

How reproducible:
always

Steps to Reproduce:
# run_init service pkcsslotd status
Authenticating root.
Password: 
pkcsslotd is stopped
# run_init service pkcsslotd start
Authenticating root.
Password: 
Starting pkcsslotd:                                        [  OK  ]
# run_init service pkcsslotd status
Authenticating root.
Password: 
pkcsslotd (pid  12315) is running...
# ps -efZ | grep pkcsslotd
system_u:system_r:initrc_t:s0   root     12315     1  0 19:18 ?        00:00:00 /usr/sbin/pkcsslotd
unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 root 12330 12100  0 19:19 pts/1 00:00:00 grep pkcsslotd
# 
  
Actual results:
* pkcsslotd runs as initrc_t

Expected results:
* pkcsslotd runs in its own SELinux domain
Comment 2 Milos Malik 2012-04-10 16:39:42 EDT
The daemon is not confined by SELinux. Please help SELinux folks to create a suitable policy module. You know that we should minimize the number of programs running as initrc_t, don't you?
Comment 3 RHEL Product and Program Management 2012-07-10 04:40:51 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2012-07-10 21:44:27 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 5 RHEL Product and Program Management 2012-09-07 01:36:50 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 7 Miroslav Grepl 2013-01-03 10:18:14 EST

*** This bug has been marked as a duplicate of bug 855834 ***

Note You need to log in before you can comment on or make changes to this bug.