This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 811337 - Firstboot: Already registered screen is presented after registering and clicking back
Firstboot: Already registered screen is presented after registering and click...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Bryan Kearney
Entitlement Bugs
:
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-04-10 14:14 EDT by Michael Stead
Modified: 2013-01-10 06:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:09:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Stead 2012-04-10 14:14:06 EDT
Description of problem:
During firstboot, if the user registers the system and continues to click the back button, eventually the "Your system was registered for updates during installation" screen will be presented. When next is clicked, the user skips the subscription-manager screens and is taken to the "Create User" screens.

The user can not re-register the system.


Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1. launch firstboot.
2. On Set up software Updates, click YES, then Forward
3. Select "I'd like to receive updates from RHN..." - then forward.
4. Progress through the registration screens until the system is successfully registered, and you are at the "Create User" screen.
5. Click the back button a few times and you will be shown the "Your system was registered for updates during installation".
  
Actual results:
You are shown the Set Up Software Updates screen with a message of "Your system was registered for updates during installation".

Expected results:
You are shown the set Up Software Updates screen allowing you to choose a server.
Comment 2 James Bowes 2012-04-10 14:55:18 EDT
This is caused by the rhsm_login screen lazily unregistering you when you try to register again. I've fixed this by simply unregistering any time you return to this screen (after first using it to register).
Comment 3 James Bowes 2012-04-10 16:00:40 EDT
Fixed in master 4c5cc0858e
and RHEL6.3 b82599710610b9

should be in subscription-manager-0.99.13-1
Comment 6 J.C. Molet 2012-04-12 14:31:10 EDT
subscription-manager-firstboot-1.0.0-1.git.11.f42a186.el6.x86_64

This seems to work now in the above version ^^

I've tested this by going through firstboot all the way to the last module/screen and then clicking back to the welcome screen and then going back through again.  It did not say I was already registered at any point.

VERIFIED.
Comment 8 errata-xmlrpc 2012-06-20 09:09:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.