Bug 811342 - Intel driver problem with icons with transparent backgrounds
Intel driver problem with icons with transparent backgrounds
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-intel (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
: OtherQA
Depends On:
Blocks: 842499
  Show dependency treegraph
 
Reported: 2012-04-10 14:42 EDT by Gary Gatling
Modified: 2013-02-21 03:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:07:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
fix transparency bug (554 bytes, patch)
2012-04-10 14:44 EDT, Gary Gatling
no flags Details | Diff

  None (edit)
Description Gary Gatling 2012-04-10 14:42:15 EDT
Description of problem:

With a Intel(R) Core(TM) i7-2630QM CPU or a Intel(R) Core(TM) i7-2670QM CPU I have an issue with icons with transparent backgrounds. The backgrounds show black instead of transparent. 

http://i.imgur.com/CvNe7.png

I searched on the web and found a patch for debian based systems. I was able to create a patch for RHEL 6 based on the debian patch. For an example see:

https://launchpadlibrarian.net/84357739/xserver-xorg-video-intel_2.15.901-1ubuntu2.1.debdiff

Here is another screenshot with the patch applied after a reboot:

http://i.imgur.com/Nnwwt.jpg

Version-Release number of selected component (if applicable):

xorg-x11-drv-intel-2.16.0-1

How reproducible:


Steps to Reproduce:
1. Get machine that uses i965 such as a recent laptop with hybrid graphics with an Intel(R) Core(TM) i7 CPU/integrated GPU.
2. ssh -X to another red hat machine.
3. Run gtk GUI app back to your display. (I used virt-manager in my example)
  
Actual results:
Icons in apps should have transparent backgrounds.

Expected results:
notice how transparent backgrounds are not transparent but are instead black.

Additional info:
Comment 1 Gary Gatling 2012-04-10 14:44:09 EDT
Created attachment 576557 [details]
fix transparency bug

This patch fixes the issues I described with remote ssh X apps.
Comment 3 RHEL Product and Program Management 2012-07-10 04:54:01 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2012-07-10 22:07:38 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 6 Adam Jackson 2012-09-10 17:50:08 EDT
The corresponding launchpad bug has this breadcrumb:

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/785280/comments/21

Upstream commit 2174f8401 is included in intel 2.17.0 and later, so this should already be fixed by the intel driver rebase in 6.4.  MODIFIED.
Comment 8 Tomas Pelka 2012-12-21 05:25:00 EST
Dear reporter,

I would like ask you for recheck with newest intel driver.

Thanks for feedback
Tom
Comment 9 Gary Gatling 2013-01-08 16:33:06 EST
Hello.

Still having trouble with transparency with some icons when sshing to a remote computer.

I have  xorg-x11-drv-intel-2.16.0-4.el6.x86_64 installed.

Sorry for delay in getting back to you about this.
Comment 10 Tomas Pelka 2013-01-09 06:38:13 EST
Gary 

this seems to be older than what we have in 6.4 candidate, since the newest is xorg-x11-drv-intel-2.20.8-1.el6 and only this one should contain the patch (Adam correct me if I'm wrong).

Do you have an access to latest rhel6.4 composes? If not Adam can we provide test package?
Comment 11 Gary Gatling 2013-01-09 11:01:18 EST
I don't think we have access to that because I asked Daniel to look for the package for me in our customer portal today and he could not find version 2.20. (Daniel is one of our employees who has access to https://rhn.redhat.com/rhn/software/channels/Beta.do )

Sorry about that. If you can make it available some other way I can test it though. Cheers.
Comment 12 Gary Gatling 2013-01-09 11:06:06 EST
The newest one we can see is xorg-x11-drv-intel-2.20.2-2.el6.x86_64 which I assume is not fixed. Thanks.
Comment 14 errata-xmlrpc 2013-02-21 03:07:01 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0303.html

Note You need to log in before you can comment on or make changes to this bug.