Bug 811366 - stap-serverd runs as initrc_t
stap-serverd runs as initrc_t
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.3
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks: 832330 1116380
  Show dependency treegraph
 
Reported: 2012-04-10 16:00 EDT by Milos Malik
Modified: 2014-10-14 03:56 EDT (History)
5 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-247.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 03:56:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2012-04-10 16:00:11 EDT
Description of problem:


Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.7.19-145.el6.noarch
selinux-policy-doc-3.7.19-145.el6.noarch
selinux-policy-mls-3.7.19-145.el6.noarch
selinux-policy-3.7.19-145.el6.noarch
selinux-policy-minimum-3.7.19-145.el6.noarch
systemtap-server-1.7-3.el6.x86_64

How reproducible:
always

Steps to Reproduce:
# service stap-server status
No managed stap-server is running
# run_init service stap-server start
Authenticating root.
Password: 
Starting stap-server -a "x86_64" -r "2.6.32-220.el6.x86_64" -u "stap-server" --log "/var/log/stap-server/log"
                                                           [  OK  ]
# service stap-server status
stap-server -a "x86_64" -r "2.6.32-220.el6.x86_64" -u "stap-server" -n "15947" --log "/var/log/stap-server/log" running as PID 15947
# ps -efZ | grep initrc_t
system_u:system_r:initrc_t:s0   155      15947     1  0 21:58 ?        00:00:00 /usr/libexec/systemtap/stap-serverd -r 2.6.32-220.el6.x86_64 -a x86_64 --log=/var/log/stap-server/log
unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 root 16006 12100  0 21:59 pts/1 00:00:00 grep initrc_t
# 

Actual results:
* stap-serverd runs as initrc_t

Expected results:
* stap-server runs in its own SELinux domain
Comment 1 Milos Malik 2012-04-10 16:51:35 EDT
The daemon is not confined by SELinux. Please help SELinux folks to create a suitable policy module. You know that we should minimize the number of programs running as initrc_t, don't you?
Comment 2 Frank Ch. Eigler 2012-04-11 19:42:32 EDT
We're happy to help, though are not immediately able to write a selinux
module ourselves.  Perhaps reassign this bug to someone willing/able to do so?

stap-server does a lot, so may be complicated to tie down.  For example, 
it does all of the following unprivileged operations:

- it reads files in /etc/systemtap
- it talks to the local avahi daemon
- it modifies files in its home directory /var/lib/stap-server
  (but see bug #798036)
- it creates potentially large temporary files under $TMPDIR-/var/tmp
- it reads files under /usr/lib/debug and /lib/modules and elsewhere
- it runs make / gcc / the whole stratum of kernel-build tools/scripts
- it might even be configured to make outgoing network connections to
  other nearby stap-servers
Comment 3 RHEL Product and Program Management 2012-07-10 04:38:30 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2012-07-10 21:51:30 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 5 Frank Ch. Eigler 2012-08-10 18:45:14 EDT
See also bug #798036, another selinux enforcement issue.
Comment 6 RHEL Product and Program Management 2012-12-14 03:36:02 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 9 Lukas Vrabec 2014-04-29 11:32:43 EDT
Patch sent to Miroslav.
Comment 11 Lukas Vrabec 2014-05-02 08:18:58 EDT
commit 444215373f4d5cd6c832816aaa588e00952cdc5c
Author: Lukas Vrabec <lvrabec@redhat.com>
Date:   Wed Apr 23 15:03:59 2014 +0200

    Added stapserver policy
Comment 14 Lukas Vrabec 2014-06-23 04:59:16 EDT
Milos,

Is it necessary to add this capability? Or everything run fine and you just see this AVC?
Comment 15 Lukas Vrabec 2014-07-08 08:57:09 EDT
patch sent.
Comment 18 Lukas Vrabec 2014-07-28 19:39:17 EDT
patch sent.
Comment 20 errata-xmlrpc 2014-10-14 03:56:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1568.html

Note You need to log in before you can comment on or make changes to this bug.