Bug 811373 - Add KeepAlive on to vhost in conductor.conf
Add KeepAlive on to vhost in conductor.conf
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-configure (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: John Eckersberg
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 16:15 EDT by Mike Orazi
Modified: 2012-05-15 16:50 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 16:50:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Orazi 2012-04-10 16:15:54 EDT
Adding KeepAlive on to vhost in conductor.conf should result in a significant performance improvement when a large number of static resources are fetched.

Might also want to tune MaxKeepAliveRequests + KeepAliveTimeout
Comment 1 Mike McCune 2012-04-10 17:41:46 EDT
The associated bug for CFSE that is tracking this is:

https://bugzilla.redhat.com/show_bug.cgi?id=811011

we saw *significant* speed improvements, page render times went from 6-7 seconds down to 1-2.
Comment 2 John Eckersberg 2012-04-12 11:51:35 EDT
Patch posted to list

https://fedorahosted.org/pipermail/aeolus-devel/2012-April/009972.html
Comment 3 John Eckersberg 2012-04-12 14:58:37 EDT
Fixed in build https://brewweb.devel.redhat.com/buildinfo?buildID=209008
Comment 5 wes hayutin 2012-04-17 12:41:44 EDT
[root@qeblade30 ~]# cat /etc/httpd/conf.d/aeolus-conductor.conf | grep -i KeepAlive
  KeepAlive On

[root@qeblade30 conf]# cat /usr/share/aeolus-configure/modules/aeolus/files/aggregator-httpd-ssl.conf | grep -i Keep
  KeepAlive On
[root@qeblade30 conf]#

[root@qeblade30 conf]# cat /usr/share/aeolus-configure/modules/aeolus/files/aggregator-httpd.conf | grep -i Keep
  KeepAlive On




[root@qeblade30 ~]# rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-configure-2.5.3-1.el6.noarch
aeolus-all-0.8.9-1.el6.noarch
aeolus-conductor-doc-0.8.9-1.el6.noarch
aeolus-conductor-daemons-0.8.9-1.el6.noarch
aeolus-conductor-0.8.9-1.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
Comment 6 errata-xmlrpc 2012-05-15 16:50:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0586.html

Note You need to log in before you can comment on or make changes to this bug.