Bug 811410 - F17 Beta RC4 desktop live does not boot via EFI after being written with dd
F17 Beta RC4 desktop live does not boot via EFI after being written with dd
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 20:46 EDT by Adam Williamson
Modified: 2012-05-08 19:11 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 19:11:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2012-04-10 20:46:41 EDT
If I take the F17 Beta RC4 x86-64 desktop live and write it to USB with dd, it shows up as EFI bootable. However, if I try to boot it via EFI, this doesn't totally work.

It makes it to grub and shows me the grub graphical menu as it should. However, when proceeding (whether by hitting enter or waiting for the timeout), it stays showing the graphical grub screen with no text for a while, with a cursor appearing and disappearing a couple of times. It then finally displays the usual 'allocating foobar for vmlinuz' or something like that message - but after a much longer delay than you usually see when booting EFI from a USB stick - and then, a few seconds later, simply reboots the system.

I've tried several times and with two different USB sticks and this is reliably reproducible on my hardware at least. I checked the sha256sum of the image and it was good.

Booting the same stick via BIOS emulation works, but installation to hard disk fails: I'm filing a separate bug for that.
Comment 1 Brian Lane 2012-04-12 18:27:12 EDT
I also see this with RC4 netinst.iso so it isn't limited to live.

I get a black screen and no text right before the reboot. I'm fairly sure this must be a kernel problem. I have also seen it when using a custom boot.iso with only the EFI partition added, not the MAC EFI partition so that isn't the cause.

The same iso written to usb with livecd-iso-to-disk boots just fine on EFI so this has to be related to booting from a hybridiso usb stick.
Comment 2 Brian Lane 2012-04-13 17:45:26 EDT
grub-efi-0.97-89.fc17.x86_64 fixes this for me. I built a test boot.iso dd'd it to a USB stick and successfully booted it on EFI and Mac EFI.
Comment 3 Chris Murphy 2012-04-28 22:47:50 EDT
TC2 Live-Desktop ISO dd'd to a USB stick is bootable on Mac EFI, however verification fails when choosing Verify and Boot Fedora from the GRUB menu (2nd option). User is inadequately informed of the failure. 

For dual boot installation on Apple hardware, the bug results in Bug 817262: File system errors left uncorrected, failure to install along side Mac OS.
Comment 4 Adam Williamson 2012-05-08 19:11:16 EDT
Confirmed fixed as of TC3. The other issues Chris reports are not related to this bug.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.