This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 811422 - lldpad: CEE DCBX: advertise bits may be reset to defaults at init
lldpad: CEE DCBX: advertise bits may be reset to defaults at init
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lldpad (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Petr Šabata
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 21:59 EDT by john.r.fastabend
Modified: 2012-06-20 10:15 EDT (History)
7 users (show)

See Also:
Fixed In Version: lldpad-0.9.43-16.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 10:15:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The suggested patch ported for the 6.3 package (734 bytes, patch)
2012-04-11 06:22 EDT, Petr Šabata
no flags Details | Diff

  None (edit)
Description john.r.fastabend 2012-04-10 21:59:40 EDT
The user may use dcbtool commands to clear advertise bits on CEE DCBX feature attributes (PFC, PG, APP). These are being lost across ifdown/ifup sequences and default values are being restored. The fix is to only set the values to defaults if the user has not explicitly enabled them. This default behavior was added to reduce DCBX configuration but missed this case.

The patch below resolves the issue:

commit 879e202f0c1817be4e0a70298c962d99a785cfac
Author: john fastabend <john.r.fastabend@intel.com>
Date:   Fri Mar 2 04:15:22 2012 +0000

    lldpad: CEE DCBX: only enable DCBX by default if not explicitly set


http://www.open-lldp.org/git/?p=lldp/open-lldp.git;a=commit;h=879e202f0c1817be4e0a70298c962d99a785cfac

Thanks,
John
Comment 2 Petr Šabata 2012-04-11 06:22:21 EDT
Created attachment 576739 [details]
The suggested patch ported for the 6.3 package
Comment 6 Petr Šabata 2012-04-12 11:24:30 EDT
Pushed as 0.9.43-16.
Comment 11 kavindya.s.deegala 2012-05-09 20:12:14 EDT
Verification passed with RHEL 6.3 Snap1 (lldpad-0.9.43-18.el6.x86_64.rpm)
Comment 12 errata-xmlrpc 2012-06-20 10:15:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0901.html

Note You need to log in before you can comment on or make changes to this bug.