Bug 811496 - [abrt] mysql-server-5.5.21-1.fc16: my_hash_sort_utf8: Process /usr/libexec/mysqld was killed by signal 11 (SIGSEGV)
[abrt] mysql-server-5.5.21-1.fc16: my_hash_sort_utf8: Process /usr/libexec/my...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mysql (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom Lane
Fedora Extras Quality Assurance
abrt_hash:1cb47330a055149e5dd8393b886...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-11 05:26 EDT by Georg Greve
Modified: 2012-04-12 03:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-12 03:17:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: maps (8.98 KB, text/plain)
2012-04-11 05:26 EDT, Georg Greve
no flags Details
File: backtrace (10.14 KB, text/plain)
2012-04-11 05:26 EDT, Georg Greve
no flags Details

  None (edit)
Description Georg Greve 2012-04-11 05:26:01 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/libexec/mysqld --defaults-file=/home/greve/.local/share/akonadi/mysql.conf --datadir=/home/greve/.local/share/akonadi/db_data/ --socket=/home/greve/.local/share/akonadi/socket-katana.lair/mysql.socket
crash_function: my_hash_sort_utf8
executable:     /usr/libexec/mysqld
kernel:         3.3.1-3.fc16.x86_64
pid:            6696
pwd:            /home/greve/Documents
reason:         Process /usr/libexec/mysqld was killed by signal 11 (SIGSEGV)
time:           Wed 11 Apr 2012 10:22:08 AM CEST
uid:            1000
username:       greve

backtrace:      Text file, 10379 bytes
maps:           Text file, 9192 bytes

build_ids:
:36f57a1f3d3f4436f63d1aac473a777597dce5dc
:89017ab0b75e533e4294f74ee8f7db3daceea536
:34e8b3cee73a6d0b8ac17c69ba4b1170724db64c
:0d660a4db2aecb2346e3ef73975137341f48baac
:0ce9819eb7014de7e72eec40979dd5e4d6566dca
:3ba5302e34546a45e9a85ac3429e7bc6ed624011
:638db099ff5fb986d1a092629d1bb1dca5be4904
:e5429e0905bedecc534b057783916ba43e06a66e
:dacf32a9a2f2b5077ba944e7b835cca6f637f78f
:0f0c9eed63ed279ceb0aef109eff8bcbb351e4bb
:888e650848c123e0c145e1bbf100f639bd8b308e
:3843cf1dd11e283de3457f1edf634bfdd910b8e5
:f1eb6e4e907e1e42f557c5b8dc851c407c6f4ac4
:4b4285058f7f6b39b7e7c45df83fd36c6833bfe4
:2639b5594fe4d7897db63ecd1ebb9681438317a8
:75eaece6e0d1e075520cdfad5c398fdab4370846
:e2d68a0ee0872365dcc8c6640b7cd7b94c8276f2
:b9d3a4213a482d034bebc7dc1ed2901a734a894d
:ced174aa0f6fc21a03a8891d8b372c68e705c159
:a28b15796672928bb44b262c88052ae601bf5955
:a4d9d534ebc598a7e2a9ee7ba161e2298a685448
:1a212c7f1515542b310ba92f6109efc9b5bf2b6e
:ee2f04900ae1f07517d91eba300ef385fccab1b8

dso_list:
:/lib64/libm-2.14.90.so glibc-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1330366199
:/usr/libexec/mysqld mysql-server-5.5.21-1.fc16.x86_64 (Fedora Project) 1332067144
:/lib64/libfreebl3.so nss-softokn-freebl-3.13.3-1.fc16.x86_64 (Fedora Project) 1332067123
:/lib64/libresolv-2.14.90.so glibc-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1330366199
:/lib64/libgssapi_krb5.so.2.2 krb5-libs-1.9.3-1.fc16.x86_64 (Fedora Project) 1333231418
:/lib64/libpthread-2.14.90.so glibc-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1330366199
:/lib64/libcrypto.so.1.0.0g openssl-1.0.0g-1.fc16.x86_64 (Fedora Project) 1327611217
:/lib64/libkrb5.so.3.3 krb5-libs-1.9.3-1.fc16.x86_64 (Fedora Project) 1333231418
:/lib64/libcrypt-2.14.90.so glibc-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1330366199
:/lib64/libkeyutils.so.1.4 keyutils-libs-1.5.2-1.fc16.x86_64 (Fedora Project) 1320287316
:/lib64/libdl-2.14.90.so glibc-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1330366199
:/lib64/libkrb5support.so.0.1 krb5-libs-1.9.3-1.fc16.x86_64 (Fedora Project) 1333231418
:/usr/lib64/libssl.so.1.0.0g openssl-1.0.0g-1.fc16.x86_64 (Fedora Project) 1327611217
:/lib64/libc-2.14.90.so glibc-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1330366199
:/lib64/librt-2.14.90.so glibc-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1330366199
:/lib64/libgcc_s-4.6.3-20120306.so.1 libgcc-4.6.3-2.fc16.x86_64 (Fedora Project) 1332414319
:/lib64/libz.so.1.2.5 zlib-1.2.5-6.fc16.x86_64 (Fedora Project) 1327611213
:/lib64/ld-2.14.90.so glibc-2.14.90-24.fc16.6.x86_64 (Fedora Project) 1330366199
:/lib64/libk5crypto.so.3.1 krb5-libs-1.9.3-1.fc16.x86_64 (Fedora Project) 1333231418
:/usr/lib64/libstdc++.so.6.0.16 libstdc++-4.6.3-2.fc16.x86_64 (Fedora Project) 1332414319
:/lib64/libcom_err.so.2.1 libcom_err-1.41.14-2.fc15.x86_64 (Fedora Project) 1320287314
:/lib64/libaio.so.1.0.1 libaio-0.3.109-4.fc16.x86_64 (Fedora Project) 1320287321
:/lib64/libselinux.so.1 libselinux-2.1.6-6.fc16.x86_64 (Fedora Project) 1329388198

smolt_data:
:
:
:General
:=================================
:UUID: 598ef839-9791-41b2-975d-01fe34a8fd2a
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 4983.86
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 4
:CPU Speed: 2501
:System Memory: 7870
:System Swap: 5919
:Vendor: LENOVO
:System: 42992PG ThinkPad X220 Tablet
:Form factor: Notebook
:Kernel: 3.3.0-8.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:7247:6058:8667) pci, None, PCI/ISA, QM67 Express Chipset Family LPC Controller
:(4480:59427:6058:8667) pci, sdhci-pci, BASE, N/A
:(32902:294:6058:8667) pci, i915, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:7190:6058:8667) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:6058:8667) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:6058:8667) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(32902:7192:6058:8667) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 5
:(32902:7200:6058:8667) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(32902:5378:6058:8654) pci, e1000e, ETHERNET, 82579LM Gigabit Network Connection
:(32902:7213:6058:8667) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7202:6058:8667) pci, i801_smbus, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(32902:133:32902:4881) pci, iwlwifi, NETWORK, Centrino Advanced-N 6205 AGN
:(32902:7171:6058:8667) pci, ahci, STORAGE, 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
:(32902:7229:6058:8667) pci, serial, 16550_SERIAL, 6 Series/C200 Series Chipset Family KT Controller
:(32902:7206:6058:8667) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:260:6058:8667) pci, agpgart-intel, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:7226:6058:8667) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_katana-lv_root / ext4 4096 4096 13092922 8734301 8603267 3276800 2878875 2878875
:/dev/sda1 /boot ext4 1024 1024 508745 406749 381149 128016 127737 127737
:/dev/mapper/luks-12c234ee-b666-4213-bfdc-036737e1476d /home ext4 4096 4096 42584000 16549721 14417779 10665984 10365707 10365707
:

var_log_messages:
:Apr 11 10:22:08 katana kernel: [ 1389.975768] mysqld[6696] general protection ip:90894d sp:7fff4dedfc40 error:0 in mysqld[400000+859000]
:Apr 11 10:22:08 katana abrt[6699]: Saved core dump of pid 6696 (/usr/libexec/mysqld) to /var/spool/abrt/ccpp-2012-04-11-10:22:08-6696 (10784768 bytes)
Comment 1 Georg Greve 2012-04-11 05:26:05 EDT
Created attachment 576723 [details]
File: maps
Comment 2 Georg Greve 2012-04-11 05:26:08 EDT
Created attachment 576724 [details]
File: backtrace
Comment 3 Tom Lane 2012-04-11 10:02:04 EDT
Hmm, can you provide any context here?  The backtrace looks like mysql crashed during startup, which is rather surprising.  Anything unusual about your environment settings?  What's in that mysql.conf file?
Comment 4 Georg Greve 2012-04-11 12:57:43 EDT
Context as follows: 

This is the MySQL instance started by Akonadi, so the configuration file will be that provided by Akonadi by default. 

But it's not just mysql that has started semi-randomly crashing. Akonadi, Virtuoso, Firefox, Rekonq, Konqueror and some others also started to show extreme lack of stability recently. 

Not sure what causes this sudden destabilization, although I am starting to suspect the kernel, actually, as things seem much better with 3.3.0.

Not to mention that 3.3.1 also broke suspend/resume to/from memory for me.
Comment 5 Tom Lane 2012-04-11 14:02:19 EDT
I wonder whether your machine has developed hardware issues --- you might try running some memory tests.  If it is the kernel you could prove it by reverting to the prior version for awhile.

Anyway it sounds a whole lot like this is not a mysql bug but some external factor that's affecting multiple programs.
Comment 6 Georg Greve 2012-04-12 03:17:53 EDT
Hi Tom,

Good call!

Yes, it very much looked like a more generic issue.

Reverting to Kernel 3.3.0 seemed to fix the issue, at least the applications suddenly seemed to behave normal again, and suspend/resume worked.

I still thought it was a good call to question memory -- the thought had also crossed my mind, as well, but I was travelling all of yesterday, so did not follow up on it -- and indeed memtest found that the second 4 GB RAM module was defective. After pulling it out, Kernel 3.3.1 also seems to be fine again, including for suspend/resume.

Why 3.3.0 behaved differently, and how that exactly came to pass, I guess I won't actually find out, but in any case this issue can be closed.

Thanks for your help!

Note You need to log in before you can comment on or make changes to this bug.