Bug 811522 - system cannot be registered for SAM using headpin cli command
system cannot be registered for SAM using headpin cli command
Status: CLOSED NOTABUG
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.0.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Bryan Kearney
Tazim Kolhar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-11 06:30 EDT by Tazim Kolhar
Modified: 2016-04-25 20:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-11 07:44:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tazim Kolhar 2012-04-11 06:30:37 EDT
Description of problem:
There is no option to register a system with sam manuall,
using headpin cli commands.

Version-Release number of selected component (if applicable):
[root@ibm-hs22-03 rhsm]# rpm -qa katello-headpin
katello-headpin-0.1.145-1.el6.noarch


How reproducible:
yum install -y katello-headpin-all
katello-configure --deployment=headpin

Steps to Reproduce:
1.yum install -y katello-headpin-all
2.katello-configure --deployment=headpin
3.headpin -u admin -p admin system --help
  
Actual results:
[root@ibm-hs22-03 rhsm]# headpin -u admin -p admin system --help
Usage: headpin <options> system <action> <options>
Supported Actions:
	list           list systems within an organization
	unregister     unregister a system
	subscriptions  list subscriptions for a system
	subscribe      subscribe a system to certificate
	unsubscribe    unsubscribe a system from certificate
	info           display a system within an organization
	facts          display a the hardware facts of a system
	update         update a system
	report         systems report

Options:
  -h, --help  show this help message and exit

However, it is possible to unregister a system:
[root@ibm-hs22-03 rhsm]# headpin -u admin -p admin system list --org ACME_Corporation
--------------------------------------------------------------------------------
                   Systems List For Org [ ACME_Corporation ]

 Name                       
--------------------------------------------------------------------------------
 systemZp9c7JCgyvYNJ        
 kibSVLOd9LePP              
 Sj5Kwrfi33lh7np            
 iij15L8OU                  
 SearchSysfoRS2VLJQ7Eg5Lyv  
 SearchSysqWMfQuCASG        
 SearchSysN6e8kPRHYq7m      
 SearchSysqqtlMym6jG2j6Ms   
 2mrMjJL9DB2zrKzN           
 3R8O8TDSx                  
 jWRdwfhi7WL7hzXN           
 SearchSysjCNsL2pzJrs       
 SearchSysVXPOBopjTdyOqNo   
 SearchSysldlvQrhn          
 SearchSysZgmVLJ7m          
[root@ibm-hs22-03 rhsm]# headpin -u admin -p admin system unregister --org ACME_Corporation --name SearchSysZgmVLJ7m
Successfully unregistered System [ SearchSysZgmVLJ7m ]


Expected results:
the option of registering a system should be provided

Additional info:
Comment 2 RHEL Product and Program Management 2012-04-11 06:43:47 EDT
Thank you for your bug report. This issue was evaluated for inclusion
in the current release of Subscription Asset Manager (SAM). Unfortunately,
we are unable to address this request. Because we are in the final stages
of development in the current release, only significant, release-blocking
issues involving serious regressions and data corruption can be considered.

If you believe this issue meets the release blocking criteria as defined and
communicated to you by your Red Hat Support representative, please ask
your representative to file this issue as a blocker for the current release.
Otherwise, ask that it be evaluated for inclusion in the next release of SAM.
Comment 3 RHEL Product and Program Management 2012-04-11 07:04:08 EDT
Thank you for your bug report. This issue was evaluated for inclusion
in the current release of Subscription Asset Manager (SAM). Unfortunately,
we are unable to address this request. Because we are in the final stages
of development in the current release, only significant, release-blocking
issues involving serious regressions and data corruption can be considered.

If you believe this issue meets the release blocking criteria as defined and
communicated to you by your Red Hat Support representative, please ask
your representative to file this issue as a blocker for the current release.
Otherwise, ask that it be evaluated for inclusion in the next release of SAM.
Comment 4 Tom McKay 2012-04-11 07:44:00 EDT
Headpin only allows registration of systems via subscription-manager run on the client system.

Note You need to log in before you can comment on or make changes to this bug.