Bug 811527 - [RFE]virt-p2v should support unattended operation to meet unsupervised conversion
[RFE]virt-p2v should support unattended operation to meet unsupervised conver...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-p2v (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Richard W.M. Jones
: FutureFeature, Reopened
Depends On:
Blocks: 960054
  Show dependency treegraph
 
Reported: 2012-04-11 06:46 EDT by Cui Lei
Modified: 2015-03-12 13:27 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-12 13:27:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cui Lei 2012-04-11 06:46:31 EDT
Description of problem:
Now virt-p2v does not support unattended operation, so we can not automatic to test virt-p2v cases.Currently, virt-p2v has a big amount over 400 cases and some of them cost 2~4 hours to finish, which waste too much time to execute them manually.

We highly suggestion DEV to implement these type of features with high priority.
Target: implement a feature to make virt-p2v auto-configured, meet unsupervised conversions

Here is the description of unattended operation from Matt's relevant document:
It should be possible to specify all options on the boot command line and have the conversion process start immediately. This will make performing multiple, similar conversions simpler and less error-prone


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
This feature was a blocker of virt-p2v auto test

Expected results:
implement a feature to make virt-p2v auto-configured, meet unsupervised conversions

Additional info:
Comment 2 Rita Wu 2012-04-11 22:51:30 EDT
If it can get the settings from kernel command instead of only UI interactive, p2v will become much more efficient when customer has a lot of machines.
Comment 3 RHEL Product and Program Management 2012-07-10 03:19:53 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2012-07-10 21:57:58 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 5 Tom Lavigne 2012-09-07 11:21:16 EDT
This request was evaluated by Red Hat Product Management for 
inclusion in the current release of Red Hat Enterprise Linux.
Since we are unable to provide this feature at this time,  
it has been proposed for the next release of 
Red Hat Enterprise Linux.
Comment 8 RHEL Product and Program Management 2013-05-21 11:18:39 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.
Comment 9 Richard W.M. Jones 2013-05-21 12:50:22 EDT
Reopening.
Comment 10 Cui Lei 2013-05-21 21:53:56 EDT
As comment2 said, this feature is very useful for customer which has too much machines for p2v. Also it is very efficient to QE, as usually manually test virt-p2v cost a lot of time even not full test(over two weeks each round).
If we can do conversion automatically, which would save much time.
Please consider this bug in RHEL6.5.
Comment 16 Richard W.M. Jones 2015-03-12 13:27:36 EDT
New virt-p2v supports this, see:

http://libguestfs.org/virt-p2v.1.html#kernel-command-line-configuration

I'm closing this bug:

 - virt-p2v has been rewritten for RHEL 7.2

 - Unofficial previews of the new version are available:
   http://oirase.annexia.org/virt-p2v/

 - If a similar bug occurs with the new version of virt-p2v,
   please open a new bug against Red Hat Enterprise Linux 7 / libguestfs

Note You need to log in before you can comment on or make changes to this bug.