This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 811558 - [abrt] ibus-1.4.1-1.fc16: g_type_check_instance_cast: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
[abrt] ibus-1.4.1-1.fc16: g_type_check_instance_cast: Process /usr/bin/python...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:a9510c9de5e6fe85143c6ccf314...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-11 08:23 EDT by Chen_Min_Chin
Modified: 2012-06-14 23:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 23:04:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: dso_list (10.64 KB, text/plain)
2012-04-11 08:23 EDT, Chen_Min_Chin
no flags Details
File: build_ids (4.40 KB, text/plain)
2012-04-11 08:23 EDT, Chen_Min_Chin
no flags Details
File: backtrace (63.58 KB, text/plain)
2012-04-11 08:23 EDT, Chen_Min_Chin
no flags Details
File: maps (49.49 KB, text/plain)
2012-04-11 08:23 EDT, Chen_Min_Chin
no flags Details
File: backtrace (63.67 KB, text/plain)
2012-04-12 10:05 EDT, Chen_Min_Chin
no flags Details
File: backtrace (65.28 KB, text/plain)
2012-04-16 10:05 EDT, Flos Lonicerae
no flags Details
File: backtrace (63.28 KB, text/plain)
2012-04-21 11:51 EDT, Flos Lonicerae
no flags Details
File: backtrace (63.32 KB, text/plain)
2012-04-21 12:15 EDT, Flos Lonicerae
no flags Details

  None (edit)
Description Chen_Min_Chin 2012-04-11 08:23:02 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/bin/python /usr/share/ibus/ui/gtk/main.py
crash_function: g_type_check_instance_cast
executable:     /usr/bin/python
kernel:         3.3.1-3.fc16.x86_64
pid:            2084
pwd:            /tmp
reason:         Process /usr/bin/python was killed by signal 11 (SIGSEGV)
time:           Wed 11 Apr 2012 08:02:54 PM CST
uid:            1000
username:       chen
xsession_errors: 

backtrace:      Text file, 65105 bytes
build_ids:      Text file, 4510 bytes
dso_list:       Text file, 10893 bytes
maps:           Text file, 50677 bytes

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-truaEKDdNB,guid=4176669f39ac2035fbbf2a690000002a
:SHELL=/bin/bash
:XDG_SESSION_COOKIE=a72cb27328747f65cec09bfd00000014-1334145383.728131-1597682244
:IBUS_DATAROOTDIR=/usr/share
:GNOME_KEYRING_CONTROL=/tmp/keyring-guZyiS
:USER=chen
:USERNAME=chen
:PATH=/usr/local/bin:/usr/bin:/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/tmp
:XMODIFIERS=@im=ibus
:LANG=en_US.UTF-8
:GNOME_KEYRING_PID=1423
:IBUS_PREFIX=/usr
:GDMSESSION=gnome
:DBUS_STARTER_BUS_TYPE=session
:HOME=/home/chen
:SHLVL=1
:XDG_SEAT=seat0
:IBUS_LOCALEDIR=/usr/share/locale
:LOGNAME=chen
:LC_CTYPE=en_US.UTF-8
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-truaEKDdNB,guid=4176669f39ac2035fbbf2a690000002a
:WINDOWPATH=1
:DISPLAY=:0
:XDG_RUNTIME_DIR=/run/user/chen
:GTK_IM_MODULE=ibus
:XAUTHORITY=/var/run/gdm/auth-for-chen-MtK8z1/database

smolt_data:
:
:
:General
:=================================
:UUID: 566c1251-21c5-47a3-84f9-5022f6e6e21a
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 4388.97
:CPU Vendor: GenuineIntel
:CPU Model: Pentium(R) Dual-Core CPU       T4400  @ 2.20GHz
:CPU Stepping: 10
:CPU Family: 6
:CPU Model Num: 23
:Number of CPUs: 2
:CPU Speed: 2200
:System Memory: 3953
:System Swap: 6015
:Vendor: Acer
:System: Aspire 4736Z V2.08
:Form factor: Notebook
:Kernel: 3.3.1-3.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10816:4133:608) pci, None, HOST/PCI, Mobile 4 Series Chipset Memory Controller Hub
:(32902:10817:4133:608) pci, pcieport, PCI/PCI, Mobile 4 Series Chipset PCI Express Graphics Port
:(5772:42:6706:774) pci, ath9k, NETWORK, AR928X Wireless Network Adapter (PCI-Express)
:(32902:10544:4133:608) pci, i801_smbus, SERIAL, 82801I (ICH9 Family) SMBus Controller
:(32902:10537:4133:608) pci, ahci, STORAGE, ICH9M/M-E SATA AHCI Controller
:(32902:10521:4133:608) pci, None, PCI/ISA, ICH9M LPC Interface Controller
:(32902:10546:4133:608) pci, None, NONE, 82801I (ICH9 Family) Thermal Subsystem
:(32902:9288:4133:608) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10549:4133:608) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #2
:(32902:10548:4133:608) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #1
:(32902:10553:4133:608) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #6
:(32902:10550:4133:608) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #3
:(6523:9091:4133:608) pci, jmb38x_ms, BASE, MS Host Controller
:(6523:9089:4133:608) pci, None, BASE, Standard SD Host Controller
:(32902:10554:4133:608) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #1
:(32902:10556:4133:608) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #2
:(32902:10564:4133:608) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 3
:(32902:10560:4133:608) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 1
:(32902:10562:4133:608) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 2
:(32902:10568:4133:608) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 5
:(32902:10558:4133:608) pci, snd_hda_intel, MULTIMEDIA, 82801I (ICH9 Family) HD Audio Controller
:(32902:10551:4133:608) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #4
:(32902:10552:4133:608) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #5
:(4318:1772:4133:608) pci, nouveau, VIDEO, G98M [GeForce G 105M]
:(6523:9092:4133:608) pci, None, BASE, xD Host Controller
:(6505:4195:4133:608) pci, atl1c, ETHERNET, AR8131 Gigabit Ethernet
:(6523:9090:4133:608) pci, sdhci-pci, BASE, SD/MMC Host Controller
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/VolGroup-lv_root / ext4 4096 4096 13081819 10369578 9714218 3276800 2999003 2999003
:/dev/sda2 /boot ext4 1024 1024 508745 408993 383393 128016 127743 127743
:/dev/mapper/VolGroup-lv_home /home ext4 4096 4096 63291513 37249778 34081522 15843328 15818498 15818498
:

var_log_messages:
:Apr  8 21:23:28 localhost kernel: [12190.835534] python[2010]: segfault at 1d ip 000000370ae32fec sp 00007fff88f2c5b0 error 4 in libgobject-2.0.so.0.3000.2[370ae00000+4c000]
:Apr  8 21:23:29 localhost abrt[3931]: Saved core dump of pid 2010 (/usr/bin/python) to /var/spool/abrt/ccpp-2012-04-08-21:23:28-2010 (18530304 bytes)
:Apr 10 10:37:09 localhost kernel: [ 2792.112390] python[2001] general protection ip:370ae32fec sp:7fff6fe60740 error:0 in libgobject-2.0.so.0.3000.2[370ae00000+4c000]
:Apr 10 10:37:10 localhost abrt[3201]: Saved core dump of pid 2001 (/usr/bin/python) to /var/spool/abrt/ccpp-2012-04-10-10:37:09-2001 (18538496 bytes)
:Apr 10 19:48:53 localhost kernel: [  430.906302] python[2024]: segfault at 1d ip 000000370ae32fec sp 00007fffd9340480 error 4 in libgobject-2.0.so.0.3000.2[370ae00000+4c000]
:Apr 10 19:48:54 localhost abrt[2972]: Saved core dump of pid 2024 (/usr/bin/python) to /var/spool/abrt/ccpp-2012-04-10-19:48:53-2024 (18538496 bytes)
:Apr 11 10:56:57 localhost kernel: [  352.690446] python[1974]: segfault at 1d ip 000000370ae32fec sp 00007fffc90c5f90 error 4 in libgobject-2.0.so.0.3000.2[370ae00000+4c000]
:Apr 11 10:56:58 localhost abrt[2655]: Saved core dump of pid 1974 (/usr/bin/python) to /var/spool/abrt/ccpp-2012-04-11-10:56:57-1974 (18477056 bytes)
:Apr 11 20:02:54 localhost kernel: [  433.148614] python[2084]: segfault at 1d ip 000000370ae32fec sp 00007fffaef2e920 error 4 in libgobject-2.0.so.0.3000.2[370ae00000+4c000]
:Apr 11 20:02:55 localhost abrt[2727]: Saved core dump of pid 2084 (/usr/bin/python) to /var/spool/abrt/ccpp-2012-04-11-20:02:54-2084 (18554880 bytes)
Comment 1 Chen_Min_Chin 2012-04-11 08:23:12 EDT
Created attachment 576752 [details]
File: dso_list
Comment 2 Chen_Min_Chin 2012-04-11 08:23:15 EDT
Created attachment 576753 [details]
File: build_ids
Comment 3 Chen_Min_Chin 2012-04-11 08:23:18 EDT
Created attachment 576754 [details]
File: backtrace
Comment 4 Chen_Min_Chin 2012-04-11 08:23:22 EDT
Created attachment 576755 [details]
File: maps
Comment 5 fujiwara 2012-04-11 23:22:30 EDT
(In reply to comment #3)
> Created attachment 576754 [details]
> File: backtrace

Program terminated with signal 11, Segmentation fault.
#0  g_type_check_instance_cast (type_instance=0x12a18b0, iface_type=18624128) at gtype.c:3992
        node = <optimized out>
        iface = <optimized out>
        is_instantiatable = <optimized out>
        check = <optimized out>


I cannot reproduce your problem.
Do you still reproduce your problem?
It seems you encountered the problem when candidatepanel.hide_lookup_table() is called.
Comment 6 Chen_Min_Chin 2012-04-12 10:05:45 EDT
1.change input-type to Bopomofo.
2.type some words.
3.crash


backtrace_rating: 4
Package: ibus-1.4.1-1.fc16
OS Release: Fedora release 16 (Verne)
Comment 7 Chen_Min_Chin 2012-04-12 10:05:49 EDT
Created attachment 577075 [details]
File: backtrace
Comment 8 fujiwara 2012-04-15 21:55:25 EDT
(In reply to comment #7)
> Created attachment 577075 [details]
> File: backtrace

I cannot reproduce your problem.
Are you able to see the same problem with a new user account instead of the current account?

Which keys did you actually type on the keyboard with the enabled Bopomofo?
Comment 9 Flos Lonicerae 2012-04-16 10:05:46 EDT
1.sudo yum install ibus-table-chinese-wubi-jidian
2. change input method from ibus-pinyin to wubi
3. ibus trayicon disappeared
4. abrt-gui show up


backtrace_rating: 4
Package: ibus-1.4.1-1.fc16
OS Release: Fedora release 16 (Verne)
Comment 10 Flos Lonicerae 2012-04-16 10:05:56 EDT
Created attachment 577723 [details]
File: backtrace
Comment 11 fujiwara 2012-04-16 23:29:07 EDT
(In reply to comment #9)
> 1.sudo yum install ibus-table-chinese-wubi-jidian
> 2. change input method from ibus-pinyin to wubi
> 3. ibus trayicon disappeared
> 4. abrt-gui show up
> 
> 
> backtrace_rating: 4
> Package: ibus-1.4.1-1.fc16
> OS Release: Fedora release 16 (Verne)

I cannot reproduce your problem.
Do you still see your problem with a new user account instead of the current user account?
Comment 12 Chen_Min_Chin 2012-04-20 23:31:47 EDT
(In reply to comment #8)
> (In reply to comment #7)
> > Created attachment 577075 [details]
> > File: backtrace
> 
> I cannot reproduce your problem.
> Are you able to see the same problem with a new user account instead of the
> current account?
> 
> Which keys did you actually type on the keyboard with the enabled Bopomofo?

I press ctrl+space to enable Bopomofo.
Comment 13 Chen_Min_Chin 2012-04-20 23:45:57 EDT
(In reply to comment #8)
> (In reply to comment #7)
> > Created attachment 577075 [details]
> > File: backtrace
> 
> I cannot reproduce your problem.
> Are you able to see the same problem with a new user account instead of the
> current account?
> 
> Which keys did you actually type on the keyboard with the enabled Bopomofo?

I just add a new user account.
This problem seems not occur again.
Comment 14 Flos Lonicerae 2012-04-21 11:51:33 EDT
1.open leafpad
2.input text with ibus-pinyin
3.press ctrl+s to try to save file
4.save dialog show up and abrt pop up


backtrace_rating: 4
Package: ibus-1.4.1-1.fc16
OS Release: Fedora release 16 (Verne)
Comment 15 Flos Lonicerae 2012-04-21 11:51:43 EDT
Created attachment 579192 [details]
File: backtrace
Comment 16 Flos Lonicerae 2012-04-21 12:15:46 EDT
1. focus cursor on the text input box
2. press 'ctrl+space' to activate ibus-pinyin
3. when input a word, abrt pop up


backtrace_rating: 4
Package: ibus-1.4.1-1.fc16
OS Release: Fedora release 16 (Verne)
Comment 17 Flos Lonicerae 2012-04-21 12:15:57 EDT
Created attachment 579205 [details]
File: backtrace
Comment 18 fujiwara 2012-04-22 22:52:03 EDT
(In reply to comment #12)
> > Which keys did you actually type on the keyboard with the enabled Bopomofo?
> 
> I press ctrl+space to enable Bopomofo.

No, no. I'd like to know which key combinations on your keyboard you typed to output Chinese chars after Bopomofo is enabled with ctrl+space keys.

(In reply to comment #13)
> I just add a new user account.
> This problem seems not occur again.

OK, so I think your problem depends on the user preferences.
Please find the differences between the current user and the new user.
Probably I think you could move the dot files under $HOME to another place to check which file effects your problem.
E.g.

% mv $HOME/.gconf /var/tmp/your_user/.
And log out and log in the session again.
Comment 19 fujiwara 2012-04-22 22:58:32 EDT
(In reply to comment #15)
> Created attachment 579192 [details]
> File: backtrace

(In reply to comment #17)
> Created attachment 579205 [details]
> File: backtrace

I think those backtraces don't clarify the problem.

Do you still see your problem with a new user account instead of the current
user account?
Comment 20 Flos Lonicerae 2012-05-01 08:45:56 EDT
Hi,

I don't see this problem when I use a new user account. But since the last time I met the problem, I have updated the ibus-pinyin package from 1.4.0-15 to 1.4.0-16.

I don't know whether the problem was solved by this update. Both my old account and new accound don't meet this problem.
Comment 21 fujiwara 2012-05-01 22:09:08 EDT
(In reply to comment #20)
> I don't see this problem when I use a new user account. But since the last time
> I met the problem, I have updated the ibus-pinyin package from 1.4.0-15 to
> 1.4.0-16.

I don't think the ibus-pinyin update is the problem. I cannot reproduce your problem.
OK, since you don't see your problem with a new user account, I think it depends on your local settings.

Please find which file is the problem in your $HOME. Probably it would be good to check the dot files/directories in your $HOME.

e.g.

1. Move a dot file
% cd $HOME
% mv .foo /var/tmp/your_account/.

2. Restart ibus to click "Restart" on ibus status icon menu.
3. Check if your problem can be reproduced.
Comment 22 fujiwara 2012-05-08 05:17:56 EDT
Any updates?

Note You need to log in before you can comment on or make changes to this bug.