Bug 811593 - Feedback when not providing options is not consistent
Feedback when not providing options is not consistent
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 5.9
Assigned To: William Poteat
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-04-11 09:46 EDT by Bryan Kearney
Modified: 2013-01-07 22:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:50:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Kearney 2012-04-11 09:46:19 EDT
The following commands all behave differently when no options are provided:

subscribe
unsubscribe
envrionments
import
repos

for example subscribe shows:

Error: This command requires that you specify a pool with --pool or use --auto.


and repos shows:

Error: This command requires that you specify a pool with --pool or use --auto.


and unsubscibe actually shows the full text. Pick one model, and standardize across all the commands.

Additionally, these commands:

subscribe
unsubscribe

should check for registration before parsing the options.
Comment 1 Bryan Kearney 2012-04-11 09:52:16 EDT
Also, the redeem command.
Comment 2 RHEL Product and Program Management 2012-04-11 09:57:51 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Bryan Kearney 2012-04-11 10:03:04 EDT
Add config to this list too.
Comment 4 William Poteat 2012-06-12 15:40:42 EDT
Checking for registration before the unsubscribe command does not work with offline setup. It was not put in.

Config defaults to --list as before, it is the logical default.

Error messages have been standardized.

Commit 42e23b7bf6be4086d70b44a37dc41c5e987193b8 in master.
Comment 5 J.C. Molet 2012-06-19 12:41:51 EDT
Testing with: subscription-manager-1.0.4-1.git.3.1768f90.el5

[root@jmolet-vm0 ~]# subscription-manager subscribe
Error: This command requires that you specify a pool with --pool or use --auto.

[root@jmolet-vm0 ~]# subscription-manager unsubscribe
Error: This command requires that you specify one of --serial or --all.

[root@jmolet-vm0 ~]# subscription-manager environments
Error: This command requires that you specify an organizaiton with --org

[root@jmolet-vm0 ~]# subscription-manager import
Error: This command requires that you specify a certificate with --certificate.


subscription-manager repos will now default to --list, see Bug 811594 .

marking VERIFIED
Comment 7 errata-xmlrpc 2013-01-07 22:50:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.