Bug 811633 - channel-cert-mapping.txt is missing a mapping for product 167 "Red Hat CloudForms"
channel-cert-mapping.txt is missing a mapping for product 167 "Red Hat CloudF...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager-migration-data (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Alex Wood
:
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-04-11 11:11 EDT by John Sefler
Modified: 2012-06-20 09:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:37:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-04-11 11:11:03 EDT
Description of problem:
In the master product-baseline definition, the following RHN Channels are mapped to the Red Hat CloudForms product ID 167.  As such, the channel-cert-mapping.txt file should also have these mappings, but currently they do not.

http://git.app.eng.bos.redhat.com/?p=rcm/rhn-definitions.git;a=blob;f=cdn/product-baseline.json;hb=HEAD
        "Name": "Red Hat CloudForms", 
        "Product ID": "167", 
        "RHN Channels": [
            "rhel-x86_64-server-6-cf-ae-1", 
            "rhel-x86_64-server-6-cf-ae-1-beta", 
            "rhel-x86_64-server-6-cf-ae-1-beta-debuginfo", 
            "rhel-x86_64-server-6-cf-ae-1-debuginfo", 
            "rhel-x86_64-server-6-cf-ce-1", 
            "rhel-x86_64-server-6-cf-ce-1-beta", 
            "rhel-x86_64-server-6-cf-ce-1-beta-debuginfo", 
            "rhel-x86_64-server-6-cf-ce-1-debuginfo", 
            "rhel-x86_64-server-6-cf-se-1", 
            "rhel-x86_64-server-6-cf-se-1-beta", 
            "rhel-x86_64-server-6-cf-se-1-beta-debuginfo", 
            "rhel-x86_64-server-6-cf-se-1-debuginfo"
        ]

Version-Release number of selected component (if applicable):
[root@jsefler-63server ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-1.12.1.2-1.git.2.99d0c10.el6.noarch


How reproducible:


Steps to Reproduce:
[root@jsefler-63server ~]# grep 167.pem /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
[root@jsefler-63server ~]# 

^^^ Expected that grep to find a hit on 167.pem



Additional info:
Before this can actually be fixed in subscription-manager-migration-data, it depends on the creation of a product cert by the release engineering team for product id 167 in http://git.app.eng.bos.redhat.com/?p=rcm/rhn-definitions.git;a=tree;f=product_ids/rhel-6.3
Comment 1 Alex Wood 2012-04-17 13:20:46 EDT
The cert for product ID 167 is actually available under http://git.app.eng.bos.redhat.com/?p=rcm/rhn-definitions.git;a=tree;f=product_ids/cf-1.0
Comment 2 Alex Wood 2012-04-17 13:41:59 EDT
Fixed on RHEL6.3 branch with 128cd4ec3dd0d6da9d46ed8929320c8c3211916b

Fixed on RHEL6 branch with dc268b63aa20c0589a9317c4b801a781edae74bb
Comment 4 John Sefler 2012-04-25 17:55:58 EDT
Verifying Version...
[root@jsefler-r63-server ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-1.12.1.5-1.el6.noarch

Today, the cdn/product-baseline.json contains this mapping for RHN Channels to product 167...

        "Name": "Red Hat CloudForms", 
        "Product ID": "167", 
        "RHN Channels": [
            "rhel-x86_64-server-6-cf-ce-1", 
            "rhel-x86_64-server-6-cf-ce-1-beta", 
            "rhel-x86_64-server-6-cf-ce-1-beta-debuginfo", 
            "rhel-x86_64-server-6-cf-ce-1-debuginfo", 
            "rhel-x86_64-server-6-cf-se-1", 
            "rhel-x86_64-server-6-cf-se-1-beta", 
            "rhel-x86_64-server-6-cf-se-1-beta-debuginfo", 
            "rhel-x86_64-server-6-cf-se-1-debuginfo"
        ]


The channel-cert-mapping.txt contains the same mapping:
[root@jsefler-r63-server ~]# grep 167.pem /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
rhel-x86_64-server-6-cf-ce-1: product-x86_64-3085f3bfbd2b-167.pem
rhel-x86_64-server-6-cf-ce-1-beta: product-x86_64-3085f3bfbd2b-167.pem
rhel-x86_64-server-6-cf-ce-1-beta-debuginfo: product-x86_64-3085f3bfbd2b-167.pem
rhel-x86_64-server-6-cf-ce-1-debuginfo: product-x86_64-3085f3bfbd2b-167.pem
rhel-x86_64-server-6-cf-se-1: product-x86_64-3085f3bfbd2b-167.pem
rhel-x86_64-server-6-cf-se-1-beta: product-x86_64-3085f3bfbd2b-167.pem
rhel-x86_64-server-6-cf-se-1-beta-debuginfo: product-x86_64-3085f3bfbd2b-167.pem
rhel-x86_64-server-6-cf-se-1-debuginfo: product-x86_64-3085f3bfbd2b-167.pem

[root@jsefler-r63-server ~]# openssl x509 -text -in /usr/share/rhsm/product/RHEL-6/product-x86_64-3085f3bfbd2b-167.pem | grep 1.3.6.1.4.1.2312.9.1.167. -A1
            1.3.6.1.4.1.2312.9.1.167.1: 
                ..Red Hat CloudForms
            1.3.6.1.4.1.2312.9.1.167.2: 
                ..1.0
            1.3.6.1.4.1.2312.9.1.167.3: 
                ..x86_64
            1.3.6.1.4.1.2312.9.1.167.4: 
                ..None
[root@jsefler-r63-server ~]# 


Moving Status to VERIFIED.
Comment 6 errata-xmlrpc 2012-06-20 09:37:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0823.html

Note You need to log in before you can comment on or make changes to this bug.