Bug 811761 - Jenkins slave DNS errors causing builds to halt
Jenkins slave DNS errors causing builds to halt
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
high Severity low
: ---
: ---
Assigned To: Bill DeCoste
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-11 18:37 EDT by Nam Duong
Modified: 2015-05-14 21:50 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-17 10:52:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nam Duong 2012-04-11 18:37:54 EDT
Description of problem:
A user posted to the forums: https://www.redhat.com/openshift/community/forums/openshift/issue-creating-jenkins-app-dns

I'm able to reproduce this user's problem with a sample php application (while trying to rule out DIY):
steps:
rhc app create -a static -t php-5.3
rhc app create -a ci -t jenkins-1.4
rhc app cartridge add -a static -c jenkins-client-1.4
modify file and push to queue a build
rhc app tail -a ci

Attached is the log.  Do we know of any workarounds for the user?
Comment 1 Mike McGrath 2012-04-13 12:20:30 EDT
Timeout for DNS probably too short.
Comment 2 Bill DeCoste 2012-04-13 12:24:58 EDT
I recently increased the default DNS timeout from 60000ms to 300000ms. This is configurable in the job config.
Comment 3 Bill DeCoste 2012-04-16 10:20:15 EDT
This is not a bug. Please have the user increase their timeout in the jenkins job config.
Comment 4 Meng Bo 2012-04-17 01:41:27 EDT
checked on devenv_1724 with jenkins-plugin-openshift-0.5.13,
the default timeout is 300000, and this issue won't reproduce,
mark this bug as verified.

Note You need to log in before you can comment on or make changes to this bug.