Bug 811792 - Request 'sha1' checksum indicated mandatory for RHEL5
Request 'sha1' checksum indicated mandatory for RHEL5
Status: CLOSED ERRATA
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
2.1
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: mkovacik
mkovacik
:
Depends On:
Blocks: 824613
  Show dependency treegraph
 
Reported: 2012-04-11 21:20 EDT by Matthew Mariani
Modified: 2012-08-24 07:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The sha1 checksum is mandatory for Red Hat Enterprise Linux (RHEL) 5 guest repository access. RHEL 5 Guests reports an error during checksum if the user chooses sha256 in Red Hat Update Agent (RHUA). This update adds instructions to use sha1 for RHEL 5 and 6 guest access and sha256 for RHEL 6 only. This reduces the possibility of a user selecting sha256 for RHEL 5 access.
Story Points: ---
Clone Of:
: 824613 (view as bug list)
Environment:
Last Closed: 2012-08-24 07:54:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Verifying screen log (3.48 KB, text/plain)
2012-07-26 12:30 EDT, mkovacik
no flags Details

  None (edit)
Description Matthew Mariani 2012-04-11 21:20:43 EDT
Description of problem:
'sha1' checksum is mandatory for repos being accessed by RHEL5 guests.  Suggest either 'sha1' be the default/option 1 for custom repo creation and a note indicate its mandatory if RHEL5 guest entitlement expected.


Version-Release number of selected component (if applicable):
RHUI 2.0.2

How reproducible:
Install Guide Section 5.1 (Custom Repositories), Procedure 5.6 (Create a Custom Repo)

Steps to Reproduce:
1.  Procedure 5.6, step 5 - select sha256 because its the first option
2.  Build an entitlement rpm
3.  Deploy the entitlement rpm on a RHEL5 box, yum will not function with the repo in question.
  
Actual results (RHUA menu for custom repo creation):
Algorithm to use when calculating the checksum values for repository metadata:
1 - sha256
2 - sha1
Enter value (1-2) or 'b' to abort: 1


Expected results:
Algorithm to use when calculating the checksum values for repository metadata:
1 - sha1   (Select for RHEL 5 or RHEL 6 guests)
2 - sha256 (Select for RHEL 6 guests only)
Enter value (1-2) or 'b' to abort: 1


Additional info - Example Guest yum update results
[root@rhelrpm55 ~]# yum update
Loaded plugins: rhui-lb, security
rhui-colosseum-generic-unprotected                                  | 2.6 kB     00:00    
rhui-colosseum-generic-unprotected/primary_db                       | 1.2 kB     00:00    
https://cds2.colosseum.com/pulp/repos//colosseum-generic-unprotected/repodata/primary.sqlite.bz2: [Errno -3] Error performing checksum
Trying other mirror.
rhui-colosseum-generic-unprotected/primary_db                       | 1.2 kB     00:00    
https://cds1.colosseum.com/pulp/repos//colosseum-generic-unprotected/repodata/primary.sqlite.bz2: [Errno -3] Error performing checksum
Trying other mirror.
rhui-colosseum-generic-unprotected/primary_db                       | 1.2 kB     00:00    
https://cds2.colosseum.com/pulp/repos//colosseum-generic-unprotected/repodata/primary.sqlite.bz2: [Errno -3] Error performing checksum
Trying other mirror.
rhui-colosseum-generic-unprotected/primary_db                       | 1.2 kB     00:00    
https://cds1.colosseum.com/pulp/repos//colosseum-generic-unprotected/repodata/primary.sqlite.bz2: [Errno -3] Error performing checksum
Trying other mirror.
Error: failure: repodata/primary.sqlite.bz2 from rhui-colosseum-generic-unprotected: [Errno 256] No more mirrors to try.
Comment 1 wes hayutin 2012-05-23 16:20:53 EDT
cloude commit b0dcf2499672e019aebb73527b4ad8cedb2963ec
Comment 2 mkovacik 2012-07-26 12:30:34 EDT
Created attachment 600553 [details]
Verifying screen log


Custom repo screen now displays following hint:

Algorithm to use when calculating the checksum values for repository metadata:
* Select "sha256" for RHEL6:
* Select "sha1" for either RHEL5 or RHEL6:

  1  - sha256
  2  - sha1
Enter value (1-2) or 'b' to abort: 

Verified in RHEL-6.3-RHUI-2.1-20120719.0-Server-x86_64-DVD1.iso. See screen log attached.
Comment 3 Dan Macpherson 2012-08-14 00:53:20 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The sha1 checksum is mandatory for Red Hat Enterprise Linux (RHEL) 5 guest repository access. RHEL 5 Guests reports an error during checksum if the user chooses sha256 in Red Hat Update Agent (RHUA). This update adds instructions to use sha1 for RHEL 5 and 6 guest access and sha256 for RHEL 6 only. This reduces the possibility of a user selecting sha256 for RHEL 5 access.
Comment 5 errata-xmlrpc 2012-08-24 07:54:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1205.html

Note You need to log in before you can comment on or make changes to this bug.