Bug 811810 - wifi won't accept password with 3.3.1-3.fc16.i686; wifi works with 3.1.0-7.fc16.i686
wifi won't accept password with 3.3.1-3.fc16.i686; wifi works with 3.1.0-7.fc...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-11 22:47 EDT by cgil004
Modified: 2012-04-25 16:27 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-25 16:27:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (59.68 KB, text/plain)
2012-04-12 17:55 EDT, cgil004
no flags Details
/var/log/messages (10.49 KB, text/plain)
2012-04-12 17:56 EDT, cgil004
no flags Details

  None (edit)
Description cgil004 2012-04-11 22:47:02 EDT
Description of problem:


Before running software update on all selected items after a fresh install of fc16 XFCE, 3.1.0-7's wifi was working great with no problems. After running software update and getting to 3.3.1-3 the wifi tries to connect with the password, waits about 15 seconds and then asks me for the password again. Over and over again, never connects while on this updated version.

Fedora is running on a Toshiba Satellite C655D-S5089, wifi card is a Atheros AR9285 PCI-e network adapter. Also, if it helps, the ethernet connection works perfectly fine on either kernel.

How reproducible: Easily reproducible, happens on every boot to 3.3.1-3.


Steps to Reproduce:
1. Power on and log in to 3.3.1-3
2. Try connecting and wifi password dialog will keep asking for the password
3. Boot to 3.1.0-7 and see its working fine
  
Actual results: no connection


Expected results: wifi connectivity


Additional info: 
There is only one corresponding network-script key file with the correct info.
When i do dmesg this is what I see ALL over the screen from all my attempts at working around this.

[  207.145014] wlan0: authenticate with 00:22:3f:88:36:f0 (try 1)
[  207.345196] wlan0: authenticate with 00:22:3f:88:36:f0 (try 2)
[  207.545039] wlan0: authenticate with 00:22:3f:88:36:f0 (try 3)
[  207.745047] wlan0: authentication with 00:22:3f:88:36:f0 timed out
[  214.118857] wlan0: authenticate with 00:22:3f:88:36:f0 (try 1)
[  214.318187] wlan0: authenticate with 00:22:3f:88:36:f0 (try 2)
[  214.518229] wlan0: authenticate with 00:22:3f:88:36:f0 (try 3)
[  214.718169] wlan0: authentication with 00:22:3f:88:36:f0 timed out
[  221.090103] wlan0: authenticate with 00:22:3f:88:36:f0 (try 1)
[  221.290236] wlan0: authenticate with 00:22:3f:88:36:f0 (try 2)
[  221.490238] wlan0: authenticate with 00:22:3f:88:36:f0 (try 3)
[  221.690232] wlan0: authentication with 00:22:3f:88:36:f0 timed out

Thank you for any help you can provide! I've been trying to wrap my head around why this is happening and trying to fix it the past two days but I've given up and have decided to use the older kernel for now because I need to work off of my laptop.
Comment 1 Jirka Klimes 2012-04-12 03:52:20 EDT
If the behaviour is simply affected by booting another kernel, then it's probably kernel's bug.

What NetworkManager version do you have?
$ rpm -q NetworkManager

Try whether disabling IPv6 helps:
- run nm-connection-editor, click 'Wireless' tab, select your connection, click 'Edit'
- select 'IPv6 Settings' tab and det 'Method' combobox to 'Ignore' and save the connectin

Please also grab 'dmesg' output and /var/log/messages file.
Comment 2 Tony 2012-04-12 14:53:07 EDT
Exact same problem, this time on an Aspire Aspire One D260-A.

Wifi connects perfectly with kernel kernel 3.3.0-8.fc16-i686, but fails to connect (asks repeatedly for wifi password) on kernels 3.3.1-2 and 3.3.1-3.

NetworkManager version is 0.9.2.1 and IPv6 is already set to ignore.
Comment 3 cgil004 2012-04-12 17:54:30 EDT
Network Manager is running on version 0.9.2-1.fc16.i686

I set IPv6 to ignore and still get the same issue.

I will attach dmesg output and /var/log/messages output as well.
Comment 4 cgil004 2012-04-12 17:55:36 EDT
Created attachment 577178 [details]
dmesg

dmesg output from clean boot
Comment 5 cgil004 2012-04-12 17:56:18 EDT
Created attachment 577180 [details]
/var/log/messages

/var/log/messages output on a fresh boot
Comment 6 Jirka Klimes 2012-04-17 04:37:52 EDT
Any better with kernel 3.3.1-5?

What wpa_supplicant version do you have?
$ rpm -q wpa_supplicant

Please follow these instructions to get detailed wpa_supplicant logs:
https://live.gnome.org/NetworkManager/Debugging#wpa_supplicant07
Comment 7 Tony 2012-04-17 09:16:36 EDT
(In reply to comment #6)
> Any better with kernel 3.3.1-5?
> 
> What wpa_supplicant version do you have?
> $ rpm -q wpa_supplicant
> 
> Please follow these instructions to get detailed wpa_supplicant logs:
> https://live.gnome.org/NetworkManager/Debugging#wpa_supplicant07

No better with kernel 3.3.1-5

wpa_supplicant version 0.7.3-11.fc16.i686
Comment 8 peterhoffm 2012-04-17 11:14:19 EDT
Same bug here with an x86_64 F16 Version, wpa_supplicant is also 0.7.3-11.fc16.x86_64.
With Kernel 3.3.0-8 all worked fine, since update 3.3.1-3 it didn't work, so I switched to old kernel in grub. With latest 3.3.1-5 I sit here with cable on my PC. Wifi card is a Atheros Chip: AR922X.
Comment 9 Warren Sanders 2012-04-17 16:45:39 EDT
I have 'Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)'

My messages log are filled with 'dbus-daemon[987]: ** (upowerd:1425): WARNING **: Property get or set does not have an interface string as first arg'

Not sure it has anything to do with this tho.

Tried the past three kernels with no change: 
kernel-PAE-3.3.1-2.fc16.i686
kernel-PAE-3.3.1-3.fc16.i686
kernel-PAE-3.3.1-5.fc16.i686
Comment 10 Warren Sanders 2012-04-18 11:23:26 EDT
I was successful in getting authentication by disabling KWallet completely.

Tried this as last year it seemed to be the opposite issue or similar.  See <span class="bz_closed"><a href="show_bug.cgi?id=682972#c8" title="kde-plasma-networkmanagement: WiFi authentication regression">Bug 682972</a></span>.
Comment 11 peterhoffm 2012-04-18 12:04:01 EDT
I can't confirm this, I set the network manager to store "in file (unencrypted)" and it doesn't connect.
Comment 12 Jirka Klimes 2012-04-18 12:45:31 EDT
As it is probably a driver regression (it works with older kernels), it would be
good to know what drivers (cards) do you use.

You obtain the information with, e.g.:
$ lspci
$ nmcli -f general dev list iface wlan0
...

Driver info:
$ modinfo ath9k  (substitute your driver)

Also logs from wpa_supplicant could reveal the problem. Please see comment #6
for getting the logs.

(In reply to comment #9)
> My messages log are filled with 'dbus-daemon[987]: ** (upowerd:1425): WARNING
> **: Property get or set does not have an interface string as first arg'
> 
> Not sure it has anything to do with this tho.
This seems to be unrelated. Something is calling upowerd via D-Bus with incorrect arguments.
Comment 13 peterhoffm 2012-04-18 13:21:35 EDT
Network Card is:
Network controller: Atheros Communications Inc. AR922X Wireless Network Adapter (rev 01)

modinfo ath9k:
filename:       /lib/modules/3.3.1-5.fc16.x86_64/kernel/drivers/net/wireless/ath/ath9k/ath9k.ko
license:        Dual BSD/GPL
description:    Support for Atheros 802.11n wireless LAN cards.
author:         Atheros Communications
alias:          platform:ar934x_wmac
alias:          platform:ar933x_wmac
alias:          platform:ath9k
alias:          pci:v0000168Cd00000034sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000033sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000032sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000030sv*sd*bc*sc*i*
alias:          pci:v0000168Cd0000002Esv*sd*bc*sc*i*
alias:          pci:v0000168Cd0000002Dsv*sd*bc*sc*i*
alias:          pci:v0000168Cd0000002Csv*sd*bc*sc*i*
alias:          pci:v0000168Cd0000002Bsv*sd*bc*sc*i*
alias:          pci:v0000168Cd0000002Asv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000029sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000027sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000024sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000023sv*sd*bc*sc*i*
depends:        ath9k_hw,ath9k_common,mac80211,cfg80211,ath
intree:         Y
vermagic:       3.3.1-5.fc16.x86_64 SMP mod_unload 
parm:           debug:Debugging mask (uint)
parm:           nohwcrypt:Disable hardware encryption (int)
parm:           blink:Enable LED blink on activity (int)
parm:           btcoex_enable:Enable wifi-BT coexistence (int)

There are 4 wpa_supplicant logfiles and all of them are empty.
Comment 14 peterhoffm 2012-04-20 14:24:31 EDT
I think this bug is solved with the latest kernel update, at the moment for me it all works fine. 
Can you confirm it is working (@ the others having this bug)?
So if the other ones confirm I think this bug report can be closed.
Comment 15 Dan Williams 2012-04-20 17:44:50 EDT
Note that when the kernel logs say "authenticate timed out" the driver hasn't even gotten to the point of sending the wifi passphrase yet, so it's pretty clearly a driver bug.
Comment 16 peterhoffm 2012-04-21 08:45:38 EDT
After I used the new kernel one day, I can say it works, but wifi connects very slowly when you wake up from standby (S3).
Comment 17 Jirka Klimes 2012-04-23 02:56:16 EDT
Reassigning to kernel, so it can be looked at closer.
Comment 18 Josh Boyer 2012-04-23 10:27:24 EDT
Please give 3.3.2 a try.  There was an ath9k regression that was fixed in 3.3.2.
Comment 19 cgil004 2012-04-24 21:35:54 EDT
3.3.2-1 is working for me, have not had a wifi issue yet with it. Anyone else able to confirm?
Comment 20 peterhoffm 2012-04-25 15:34:47 EDT
3.3.2-1 is working fine for me too. I think this Bug can be closed.
Comment 21 Josh Boyer 2012-04-25 16:27:20 EDT
Thanks for confirming.

Note You need to log in before you can comment on or make changes to this bug.