Bug 811878 - dev-libs:elfutils-0.153: fails 1 test
dev-libs:elfutils-0.153: fails 1 test
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: elfutils (Show other bugs)
rawhide
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Roland McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-12 04:29 EDT by Toralf Förster
Modified: 2012-04-17 07:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-17 07:55:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build log (64.07 KB, application/x-gzip)
2012-04-12 04:29 EDT, Toralf Förster
no flags Details
strip (54.00 KB, application/octet-stream)
2012-04-12 05:20 EDT, Toralf Förster
no flags Details
strip.o (33.16 KB, application/x-object)
2012-04-12 05:20 EDT, Toralf Förster
no flags Details

  None (edit)
Description Toralf Förster 2012-04-12 04:29:16 EDT
Description of problem:At an almost stable Gentoo linux image I get :

PASS: run-strip-groups.sh
../src/readelf: cannot get debug context descriptor: No DWARF information found
*** failure readelf -w debugfile1 ../src/strip
../src/readelf: cannot get debug context descriptor: No DWARF information found
*** failure readelf -w debugfile2 ../src/strip
*** failure --reloc-debug-sections not smaller ../src/strip.o
../src/readelf: cannot get debug context descriptor: No DWARF information found
*** failure readelf -w debugfile1 ../src/strip.o
../src/readelf: cannot get debug context descriptor: No DWARF information found
*** failure readelf -w debugfile2 ../src/strip.o
FAIL: run-strip-reloc.sh



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Toralf Förster 2012-04-12 04:29:58 EDT
Created attachment 576994 [details]
build log
Comment 2 Mark Wielaard 2012-04-12 05:03:59 EDT
Strange, those are the last two self tests in run-strip-groups.sh:

# self test, shouldn't impact non-ET_REL files at all.
runtest ../src/strip 0
runtest ../src/strip.o 1

Could you provide those two (src/strip and src/strip.o) object files somewhere?
Comment 3 Mark Wielaard 2012-04-12 05:05:54 EDT
Also from the logs it is as if you are building without -g, in that case there is indeed no DWARF debuginfo available. Though I would expect more self-tests failing in that case. But maybe this really is the only self tests that requires DWARF?
Comment 4 Toralf Förster 2012-04-12 05:20:05 EDT
Created attachment 577009 [details]
strip

(In reply to comment #2)
> 
> Could you provide those two (src/strip and src/strip.o) object files somewhere?
Comment 5 Toralf Förster 2012-04-12 05:20:32 EDT
Created attachment 577010 [details]
strip.o

(In reply to comment #2)
> 
> Could you provide those two (src/strip and src/strip.o) object files somewhere?
Comment 6 Mark Wielaard 2012-04-12 05:35:42 EDT
OK, so the reason is indeed that you are trying to build elfutils without -g. Then this self-test does indeed fail. Don't do that :)

I am not sure it really makes sense to support the self-tests if somebody removes the -g flag from the build. But since this seems to be the only test that does rely on it we could test for it I guess and just skip it in that case.

Do you really want/need to build things without -g?
Comment 7 Toralf Förster 2012-04-17 07:55:33 EDT
(In reply to comment #6)
> Do you really want/need to build things without -g?

No - Gentoo fixed the package - thx.

Note You need to log in before you can comment on or make changes to this bug.