Bug 811886 - win2k3-64 guest BSOD when running sandra tool on SandyBridge host
win2k3-64 guest BSOD when running sandra tool on SandyBridge host
Status: CLOSED DUPLICATE of bug 691382
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
x86_64 Windows
high Severity high
: rc
: ---
Assigned To: Eduardo Habkost
Virtualization Bugs
:
Depends On:
Blocks: 833129
  Show dependency treegraph
 
Reported: 2012-04-12 04:51 EDT by FuXiangChun
Modified: 2012-07-20 09:17 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-20 09:17:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
win2k3 guest BSOD snapshot (15.97 KB, image/png)
2012-04-12 04:53 EDT, FuXiangChun
no flags Details

  None (edit)
Description FuXiangChun 2012-04-12 04:51:35 EDT
Description of problem:
run sandra tool in win2k3-64 guest and click Hardware-->Processors, guest show BSOD

Version-Release number of selected component (if applicable):
host:
# uname -r
2.6.32-259.el6.x86_64
#rpm -qa|grep qemu
qemu-kvm-0.12.1.2-2.270.el6.x86_64

Cpu:Intel(R) Xeon(R) CPU E31225 @ 3.10GHz

guest:
win2k3 64 bit sp2

How reproducible:
100%(2/2)

Steps to Reproduce:
1./usr/libexec/qemu-kvm -M rhel6.3.0 -cpu SandyBridge --enable-kvm -m 4G -smp 8,sockets=2,cores=4,threads=1,maxcpus=10 -name rhel6.3 -uuid ddcbfb49-3411-1701-3c36-6bdbc00bedbb -rtc base=utc,clock=host,driftfix=slew -boot c -drive file=/mnt/win2k3-64.qcow2,format=qcow2,if=none,id=disk0,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=disk0,id=disk0,bootindex=1,scsi=off -netdev tap,id=hostnet1 -device virtio-net-pci,netdev=hostnet1,id=net1,mac=86:12:50:a4:32:72 -spice port=5911,disable-ticketing -vga qxl -device sga -chardev socket,id=serial0,path=/var/test1,server,nowait -device isa-serial,chardev=serial0 -balloon virtio -monitor unix:/tmp/monitor1,server,nowait -monitor stdio

2. run sandra
3.
  
Actual results:
guest BSOD 

Expected results:

guest work well


Additional info:
Comment 2 FuXiangChun 2012-04-12 04:53:46 EDT
Created attachment 576998 [details]
win2k3 guest BSOD snapshot
Comment 4 Ademar Reis 2012-04-12 14:01:36 EDT
The "sandra tool" is the one available from http://www.sisoftware.net/ ?

If yes, it's not free (for non-personal use), do we have a company-wide license to use it?
Comment 5 Ademar Reis 2012-04-12 14:03:33 EDT
Please try to reproduce it on a different CPU and/or different windows version so that we get an idea if this is a specific scenario or not.
Comment 6 Eduardo Habkost 2012-04-12 15:04:20 EDT
Sandra is known to try to read non-architectural MSRs that we don't emulate, based solely on the CPU model IDs.

Probably this is a duplicate of (or very similar in nature to) Bug 691382. It's probably not going to be fixed, unless it's an easy to emulate MSR (that was not the case on bug 691382).

Do you have any messages on the host dmesg that can help us identify the MSR being read/written?
Comment 8 FuXiangChun 2012-04-12 21:37:26 EDT
I (In reply to comment #5)
> Please try to reproduce it on a different CPU and/or different windows version
> so that we get an idea if this is a specific scenario or not.

I can reproduce it with another host(AMD Phenom(tm) 9600B Quad-Core Processor).
Comment 9 Ademar Reis 2012-04-13 11:13:18 EDT
(In reply to comment #6)
> Do you have any messages on the host dmesg that can help us identify the MSR
> being read/written?

|--> needinfo
Comment 10 FuXiangChun 2012-04-15 21:43:50 EDT
(In reply to comment #9)
> (In reply to comment #6)
> > Do you have any messages on the host dmesg that can help us identify the MSR
> > being read/written?
> 
> |--> needinfo


this is dmesg log when guest BSOD.

__ratelimit: 57 callbacks suppressed
kvm: 3114: cpu0 unhandled rdmsr: 0xce
kvm: 3114: cpu0 unhandled wrmsr: 0x198 data 0
kvm: 3114: cpu1 unhandled wrmsr: 0x198 data 0
kvm: 3114: cpu2 unhandled wrmsr: 0x198 data 0
kvm: 3114: cpu3 unhandled wrmsr: 0x198 data 0
kvm: 3114: cpu4 unhandled wrmsr: 0x198 data 0
kvm: 3114: cpu5 unhandled wrmsr: 0x198 data 0
kvm: 3114: cpu6 unhandled wrmsr: 0x198 data 0
kvm: 3114: cpu7 unhandled wrmsr: 0x198 data 0
Comment 11 Eduardo Habkost 2012-04-16 10:03:38 EDT
(In reply to comment #8)
> I (In reply to comment #5)
> > Please try to reproduce it on a different CPU and/or different windows version
> > so that we get an idea if this is a specific scenario or not.
> 
> I can reproduce it with another host(AMD Phenom(tm) 9600B Quad-Core Processor).

AMD Phenon would never run a "-cpu SandyBridge" guest. Being a different CPU model, probably it's crashing on a different MSR (and it would be a different bug). Could you open a new bug with that information?
Comment 17 Eduardo Habkost 2012-07-20 09:17:13 EDT
I will close it as duplicate of bug 691382, based on info of comment 10:
> kvm: 3114: cpu0 unhandled rdmsr: 0xce

*** This bug has been marked as a duplicate of bug 691382 ***

Note You need to log in before you can comment on or make changes to this bug.