Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 811888 - It's too slow to install freeBSD-9.0 on Fedora 17 host
Summary: It's too slow to install freeBSD-9.0 on Fedora 17 host
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: qemu
Version: 17
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Fedora Virtualization Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-12 08:55 UTC by Qunfang Zhang
Modified: 2013-01-09 12:00 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-10 12:27:57 UTC
Type: Bug


Attachments (Terms of Use)

Description Qunfang Zhang 2012-04-12 08:55:17 UTC
Description of problem:
Install a freeBSD 9.0 guest (both 32bit and 64 bit) on Fedora 17 host, it's very slow and currently the process is only 63% after 1 hour and 50 minutes. 

Version-Release number of selected component (if applicable):
kernel-3.3.0-1.fc17.x86_64
qemu-kvm-1.0-11.fc17.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install a freeBSD 32bit or 64 bit:
# virt-install --hvm --noreboot --ram 2048 --vnc --name freeBSD-32-new --network network=default --disk path=/var/lib/libvirt/images/FreeBSD-9.0-32-new.qcow2,size=20,format=qcow2 --cdrom /var/lib/libvirt/images/FreeBSD-9.0-RELEASE-i386-dvd1.iso --os-type linux

2.
3.
  
Actual results:
Installation process is very slow, only 63% after 1 hour and 50 minutes.

Expected results:


Additional info:

Comment 1 Gleb Natapov 2012-04-18 08:43:02 UTC
What qemu command line virsh creates for this? Does it uses IDE or virtio disk? If former can you provide ftrace during slow stage of installation and also try to with virtio instead.

Comment 2 Qunfang Zhang 2012-04-18 09:15:56 UTC
(In reply to comment #1)
> What qemu command line virsh creates for this?
Oh, the environment is gone and I may need to re-install it later to provide this.

>Does it uses IDE or virtio disk?
IDE disk. 

> If former can you provide ftrace during slow stage of installation and also try
> to with virtio instead.

Does freeBSD support virtio disk as well?

Comment 3 Gleb Natapov 2012-04-18 10:02:12 UTC
(In reply to comment #2)
> > to with virtio instead.
> 
> Does freeBSD support virtio disk as well?

9.0 does but not sure that support is out of the box.

Comment 8 Qunfang Zhang 2012-04-19 09:06:13 UTC
Hi, Gled and Avi
I'm a little busy today, will try it later and update bz.  Thanks.

Comment 9 Cole Robinson 2012-07-10 12:27:57 UTC
Devs couldn't reproduce, so closing WORKSFORME. Qunfang, if you can still reproduce, please try the suggestions in Comment 6 and 7


Note You need to log in before you can comment on or make changes to this bug.