Bug 811903 - Guest call trace when shutdown the guest after run dd in guest
Guest call trace when shutdown the guest after run dd in guest
Status: CLOSED DUPLICATE of bug 807515
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.9
Unspecified Unspecified
medium Severity high
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-12 05:43 EDT by Golita Yue
Modified: 2012-04-12 22:12 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-12 22:12:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
guest-serial-log (46.94 KB, text/plain)
2012-04-12 05:43 EDT, Golita Yue
no flags Details

  None (edit)
Description Golita Yue 2012-04-12 05:43:12 EDT
Created attachment 577021 [details]
guest-serial-log

Description of problem:
Guest call trace
Pid: 8, comm: migration/1 Not tainted 2.6.32-220.13.1.el6.x86_64 #1 Red Hat KVM
RIP: 0010:[<ffffffff810c63f8>]  [<ffffffff810c63f8>] stop_machine_cpu_stop+0x78/0xe0
RSP: 0018:ffff88007dcd1dd0  EFLAGS: 00000293
RAX: 0000000000000001 RBX: ffff88007dcd1df0 RCX: ffff8800022311a8
RDX: 0000000000000000 RSI: ffff88007dcfb580 RDI: ffff88007a71fd28
RBP: ffffffff8100bc0e R08: ffff88007dcd0000 R09: 00000000ffffffff
R10: 0000000000000000 R11: 0000000000000000 R12: 0000000000000000
R13: ffffffff814ecf50 R14: ffff88007dcd1df0 R15: ffff88007d0c3200
FS:  00007f8172af6700(0000) GS:ffff880002220000(0000) knlGS:0000000000000000
CS:  0010 DS: 0018 ES: 0018 CR0: 000000008005003b
CR2: 00000000014f90f8 CR3: 000000007cf52000 CR4: 00000000000006e0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Process migration/1 (pid: 8, threadinfo ffff88007dcd0000, task ffff88007dcccb00)
Stack:
 ffff88007a71fc88 ffff8800022311a0 ffffffff810c6380 ffff88007a71fd28
<0> ffff88007dcd1ee0 ffffffff810c62aa 0000000000015f80 ffff88007dcd1fd8
<0> ffff88007dcccb00 ffff8800022311a8 ffff88007dcd1ee0 ffffffff814ecf50
Call Trace:
 [<ffffffff810c6380>] ? stop_machine_cpu_stop+0x0/0xe0
 [<ffffffff810c62aa>] ? cpu_stopper_thread+0xda/0x1b0
 [<ffffffff814ecf50>] ? thread_return+0x4e/0x76e
 [<ffffffff8105e952>] ? default_wake_function+0x12/0x20
 [<ffffffff810c61d0>] ? cpu_stopper_thread+0x0/0x1b0
 [<ffffffff810908c6>] ? kthread+0x96/0xa0
 [<ffffffff8100c14a>] ? child_rip+0xa/0x20
 [<ffffffff81090830>] ? kthread+0x0/0xa0
 [<ffffffff8100c140>] ? child_rip+0x0/0x20
Code: 42 f0 41 ff 4d 00 0f 94 c0 84 c0 74 0f 8b 43 20 8b 4b 10 83 c0 01 89 4b 24 89 43 20 41 83 fc 04 74 31 44 89 e0 f3 90 44 8b 63 20 <41> 39 c4 74 ec 41 83 fc 02 75 c5 fa 66 66 90 66 66 90 eb c2 0f

Version-Release number of selected component (if applicable):
kernel-2.6.18-308.4.1.el5
kvm-83-249.el5_8.2

How reproducible:
hard to reproduce

Steps to Reproduce:
1. boot up guest (qcow2)
2. run dd if=/dev/zero of=/mnt/test bs=1000 count=1000  in guest
3. shutdown guest after step2 completed
4. check guest serial log
  
Actual results:
guest call trace

Expected results:
guest shutdown normally

Additional info:
1. host:
processor	: 1
vendor_id	: AuthenticAMD
cpu family	: 15
model		: 107
model name	: AMD Athlon(tm) Dual Core Processor 4450B
stepping	: 2
cpu MHz		: 2300.000
cache size	: 512 KB
physical id	: 0
siblings	: 2
core id		: 1
cpu cores	: 2
apicid		: 1
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch
bogomips	: 4609.61
TLB size	: 1024 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc 100mhzsteps

# free -m
             total       used       free     shared    buffers     cached
Mem:          3763       3739         23          0          3       1427
-/+ buffers/cache:       2308       1455
Swap:        16383        156      16227

2. cmd:
qemu-kvm -drive file='RHEL-Server-6.2-64-virtio.qcow2.converted_raw.raw',index=0,if=virtio,media=disk,cache=none,boot=on,format=raw -net nic,vlan=0,model=virtio,macaddr='9a:4b:96:f0:cb:ec' -net tap,vlan=0,fd=27 -m 2048 -smp 2,cores=1,threads=1,sockets=2 -cpu 'qemu64' -soundhw ac97 -spice port=8000,disable-ticketing -qxl 1 -rtc-td-hack -M rhel5.6.0 -boot c   -no-kvm-pit-reinjection -usbdevice tablet

3. The guest serial info is in attachment

4. There is a known bug in RHEL6.3, looks the reproduce steps is same but the call trace is different, for reference:
https://bugzilla.redhat.com/show_bug.cgi?id=802600
Comment 1 Golita Yue 2012-04-12 05:47:01 EDT
I created jobs for check if this is a regression, will update the result after the job finish.
https://virtlab.englab.nay.redhat.com/job/47889/details/
https://virtlab.englab.nay.redhat.com/job/47888/details/
Comment 2 Golita Yue 2012-04-12 05:51:07 EDT
Tested with kvm-83-251.el5 & kernel 2.6.18-308.el5, can reproduce this bug. (2/23)
Comment 3 Golita Yue 2012-04-12 21:01:34 EDT
This bug can be reproduced with kvm-83-249.el5 and kvm-83-249.el5_8, so not a regression.
Comment 4 Suqin Huang 2012-04-12 22:12:30 EDT

*** This bug has been marked as a duplicate of bug 807515 ***

Note You need to log in before you can comment on or make changes to this bug.