Bug 811934 - Return "(0xF0000) is already occupied" while executing relevant rhc command on win7_64 env
Return "(0xF0000) is already occupied" while executing relevant rhc command o...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: John (J5) Palmieri
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-12 07:10 EDT by bzhao
Modified: 2015-05-14 21:50 EDT (History)
3 users (show)

See Also:
Fixed In Version: rhc-0.91.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-27 16:46:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bzhao 2012-04-12 07:10:25 EDT
Description of problem:
It output "ruby 2924 child_info_fork::abort: address space needed by 'etc.so' (0xF0000) is already occupied" while executing relevant rhc command on win7_64 env

Version-Release number of selected component (if applicable):
rhc(0.88.9)
cygwin 1713
rubygems-1.8.21

How reproducible:
Always

Steps to Reproduce:
1. install rhc environment on windows 7
Install rhc env according to https://openshift.redhat.com/app/getting_started
2. execute relevant rhc command, such as:
# rhc-domain-info -l xx -p xx

  
Actual results:
It will return error messages "[main] ruby 2924 child_info_fork::abort: address space needed by 'etc.so' (0xF0000) is already occupied"

Expected results:
The command will be executed successfully without any error

Additional info:
zhaobin@zhaobinWin764PC /home/rubygems-1.8.21
$ rhc-domain-info -l bzhao22
Password:     312 [main] ruby 2924 child_info_fork::abort: address space needed by 'etc.so' (0xF0000) is already occupied
    199 [main] ruby 1476 child_info_fork::abort: address space needed by 'etc.so' (0xF0000) is already occupied
    188 [main] ruby 884 child_info_fork::abort: address space needed by 'etc.so' (0xF0000) is already occupied
    176 [main] ruby 2128 child_info_fork::abort: address space needed by 'etc.so' (0xF0000) is already occupied
    163 [main] ruby 1772 child_info_fork::abort: address space needed by 'etc.so' (0xF0000) is already occupied
    158 [main] ruby 2852 child_info_fork::abort: address space needed by 'etc.so' (0xF0000) is already occupied
    157 [main] ruby 2660 child_info_fork::abort: address space needed by 'etc.so' (0xF0000) is already occupied
    161 [main] ruby 2208 child_info_fork::abort: address space needed by 'etc.so' (0xF0000) is already occupied
    248 [main] ruby 936 child_info_fork::abort: address space needed by 'etc.so' (0xF0000) is already occupied
    246 [main] ruby 2848 child_info_fork::abort: address space needed by 'etc.so' (0xF0000) is already occupied
    239 [main] ruby 1744 child_info_fork::abort: address space needed by 'etc.so' (0xF0000) is already occupied
    441 [main] ruby 2968 child_info_fork::abort: address space needed by 'etc.so' (0xF0000) is already occupied

    241 [main] ruby 1172 child_info_fork::abort: address space needed by 'etc.so' (0xF0000) is already occupied
/usr/lib/ruby/gems/1.8/gems/rhc-0.88.9/lib/rhc-common.rb:268:in `system': Interrupt
        from /usr/lib/ruby/gems/1.8/gems/rhc-0.88.9/lib/rhc-common.rb:268:in `get_password'
        from /usr/lib/ruby/gems/1.8/gems/rhc-0.88.9/bin/rhc-domain-info:73
        from /usr/bin/rhc-domain-info:19:in `load'
        from /usr/bin/rhc-domain-info:19

zhaobin@zhaobinWin764PC /home/rubygems-1.8.21
$ gem list rhc

*** LOCAL GEMS ***

rhc (0.88.9)
Comment 1 John (J5) Palmieri 2012-04-12 11:49:29 EDT
Looking at this on my win7 virtual machine
Comment 2 John (J5) Palmieri 2012-04-12 14:19:16 EDT
Works for me.  Check that cygwin is installed correctly and that you have enough disk space

Can you install a fresh version of cygwin and try again?
Comment 3 John (J5) Palmieri 2012-04-12 16:28:20 EDT
Moving priority to low so it doesn't block staging
Comment 4 bzhao 2012-04-18 04:26:26 EDT
Env:
Windows7 Ultimate 64-bit SP1 Eng
cygwin 1.7.13-1
rubygems 1.8.22


Now i even couldn't install rhc successfully on the new windows7 64 OS, 
according to https://openshift.redhat.com/app/getting_started.

==>please see error messages below.

zhaobin@autowin7_64 /home/rubygems-1.8.22
$ gem install rhc
Building native extensions.  This could take a while...
ERROR:  Error installing rhc:
        ERROR: Failed to build gem native extension.

        /usr/bin/ruby.exe mkrf_conf.rb
Building native extensions.  This could take a while...

rake RUBYARCHDIR=/usr/lib/ruby/gems/1.8/gems/rhc-rest-0.0.14/lib RUBYLIBDIR=/usr/lib/ruby/gems/1.8/gems/rhc-rest-0.0.14/lib
sh: rake: command not found


Gem files will remain installed in /usr/lib/ruby/gems/1.8/gems/rhc-rest-0.0.14 for inspection.
Results logged to /usr/lib/ruby/gems/1.8/gems/rhc-rest-0.0.14/ext/gem_make.out
Comment 5 bzhao 2012-04-19 05:53:02 EDT
1. About use 'gem install rhc' to install rhc problem
I think the rake package should be installed automatically when i executing 'gem install rhc', but now i need to execute 'gem install rake' to install the missing rake package and then i can install rhc successfully..
Comment 6 John (J5) Palmieri 2012-04-19 14:41:19 EDT
Fotios, your mkrf_conf.rb is causing issues on windows.  Can you see if this is a known issue?  Does a compiler need to be installed?
Comment 7 Fotios Lindiakos 2012-04-24 15:13:44 EDT
Updated the dependencies to include rake. Try it now and see if there are still issues
Comment 8 bzhao 2012-04-26 04:37:11 EDT
env:
Windows7 Ultimate 64-bit SP1 Eng
cygwin 1.7.14-2
rubygems 1.8.23
rhc 0.91.10

It's fixed for return "(0xF0000) is already occupied", i can create a domain and an application successfully without any error..

But i think it have still the ERROR about missing rake on windows7, i still need to carry out "gem install rake" and then i can execute the "gem install rhc" successfully..I have added comments to bug 814811

Note You need to log in before you can comment on or make changes to this bug.