Bug 811972 - RuntimeError: Error running mkofboot: No such file or directory
RuntimeError: Error running mkofboot: No such file or directory
Status: CLOSED DUPLICATE of bug 810351
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
17
ppc64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
abrt_hash:8da385913d2778101d1bb3a3c53...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-12 08:40 EDT by Robert Knight
Modified: 2013-07-04 09:02 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-12 10:31:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb-i3HNgN (972.64 KB, text/plain)
2012-04-12 08:41 EDT, Robert Knight
no flags Details

  None (edit)
Description Robert Knight 2012-04-12 08:40:55 EDT
libreport version: 2.0.8
cmdline:        /usr/bin/python  /usr/sbin/anaconda
executable:     /usr/sbin/anaconda
exnFileName:    /tmp/anaconda-tb-i3HNgN
hashmarkername: anaconda
kernel:         3.3.0-1.fc17.ppc64
other involved packages: 
product:        Fedora
reason:         RuntimeError: Error running mkofboot: No such file or directory
release:        Cannot get release name.
time:           Thu 12 Apr 2012 08:40:13 AM EDT
version:        17

anaconda-tb-i3HNgN: Binary file, 995987 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 17.18 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iutil.py", line 181, in execWithRedirect
:    raise RuntimeError, errstr
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1932, in install
:    root=ROOT_PATH)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1091, in write
:    self.install()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 2344, in writeBootloader
:    anaconda.bootloader.write()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 383, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 247, in go_forward
:    self.dispatch()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1201, in nextClicked
:    self.anaconda.dispatch.go_forward()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/progress_gui.py", line 79, in renderCallback
:    self.intf.icw.nextClicked()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1221, in handleRenderCallback
:    self.currentWindow.renderCallback()
:RuntimeError: Error running mkofboot: No such file or directory

environ:
:LANG=en_US.UTF-8
:LC_NUMERIC=C
:TERM=linux
:TZ=America/New_York
:XAUTHORITY=/root/.Xauthority
:GLADEPATH=/tmp/updates/:/tmp/updates/data/ui/:ui/:/usr/share/anaconda/ui/:/usr/share/python-meh/
:SHLVL=0
:PYTHONPATH=/tmp/updates
:GNOME_DISABLE_CRASH_DIALOG=1
:LIBUSER_CONF=/tmp/libuser.XkCgg_
:LVM_SUPPRESS_FD_WARNINGS=1
:PWD=/
:MALLOC_PERTURB_=204
:GCONF_GLOBAL_LOCKS=1
:HOME=/tmp
:PIXMAPPATH=/tmp/updates/pixmaps/:/tmp/updates/:/tmp/product/pixmaps/:/tmp/product/:pixmaps/:/usr/share/anaconda/pixmaps/:/usr/share/pixmaps/:/usr/share/anaconda/:/usr/share/python-meh/:/usr/share/icons/Fedora/48x48/apps/
:PATH=/usr/bin:/bin:/sbin:/usr/sbin:/mnt/sysimage/bin:/mnt/sysimage/usr/bin:/mnt/sysimage/usr/sbin:/mnt/sysimage/sbin:/sbin:/usr/sbin
:MALLOC_CHECK_=2
:DISPLAY=:1
Comment 1 Robert Knight 2012-04-12 08:41:00 EDT
Created attachment 577057 [details]
File: anaconda-tb-i3HNgN
Comment 2 Robert Knight 2012-04-12 10:25:01 EDT
Steps to reproduce:

On an Apple G5 with 2Gb RAM, Radeon 9600 display.

Boot parameters: linux root=live:/dev/hda video=ofonly text

answer the question about VNC with "Start VNC".

Do a fresh install.

Installation has installed all of the (default) rpms.  Failure occurs after a significant pause.

Completely reproducible.
Comment 3 Brian Lane 2012-04-12 10:31:49 EDT
Could you check to see if the files in bug 810351 comment 2 are present on the install image?

*** This bug has been marked as a duplicate of bug 810351 ***

Note You need to log in before you can comment on or make changes to this bug.