Bug 811974 - Bad links in response when adding user.
Bad links in response when adding user.
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-api (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity high
: ---
: 3.1
Assigned To: Ori Liel
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-12 08:48 EDT by Jaroslav Henner
Modified: 2012-08-09 04:05 EDT (History)
6 users (show)

See Also:
Fixed In Version: si13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 04:05:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Henner 2012-04-12 08:48:31 EDT
Description of problem:
I added an user using ovirt-engine-sdk. It seems it is adding to /api/users, but the entity which I got as a result 
 * have href going trough /api/domains. 
 * returns HTTP 404 when following the links for role, tags and permissions rels.

Version-Release number of selected component (if applicable):
rhevm ic154.1

How reproducible:
allways
  
Actual results:
HTTP Status 404 - Could not find resource for relative : /domains/72686576-2e6c-6162-2e65-6e672e627271/users/735fad3d-f56d-4612-a4d9-854104d13923/permissions of full path: https://jh-rhsetup.rhev.lab.eng.brq.redhat.com:8443/api/domains/72686576-2e6c-6162-2e65-6e672e627271/users/735fad3d-f56d-4612-a4d9-854104d13923/permissions

Additional info:
2012-04-12 14:16:35,571 - MainThread - ovirtsdk_backendovirtsdk_backend - DEBUG - http request, conn: <ovirtsdk.web.connection.Connection object at 0x7fced9c67cd0>
2012-04-12 14:16:35,571 - MainThread - ovirtsdk_backendovirtsdk_backend - DEBUG - method: POST url: /api/users
2012-04-12 14:16:35,571 - MainThread - ovirtsdk_backendovirtsdk_backend - DEBUG - headers: {}
2012-04-12 14:16:35,572 - MainThread - ovirtsdk_backendovirtsdk_backend - DEBUG - body:
<user>
    <name>osapir</name>
    <user_name>osapir@rhev.lab.eng.brq.redhat.com</user_name>
    <roles>
        <role>
            <name>UserRole</name>
        </role>
    </roles>
    <groups>
        <group>
            <name>RDP-Group@rhev.lab.eng.brq.redhat.com/QA-All-Users</name>
        </group>
    </groups>
</user>

---
2012-04-12 14:16:35,859 - MainThread - ovirtsdk_backendovirtsdk_backend - DEBUG - http response: <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<user id="735fad3d-f56d-4612-a4d9-854104d13923" href="/api/domains/72686576-2e6c-6162-2e65-6e672e627271/users/735fad3d-f56d-4612-a4d9-854104d13923">
    <name>osapir</name>
    <link rel="permissions" href="/api/domains/72686576-2e6c-6162-2e65-6e672e627271/users/735fad3d-f56d-4612-a4d9-854104d13923/permissions"/>
    <link rel="roles" href="/api/domains/72686576-2e6c-6162-2e65-6e672e627271/users/735fad3d-f56d-4612-a4d9-854104d13923/roles"/>
    <link rel="tags" href="/api/domains/72686576-2e6c-6162-2e65-6e672e627271/users/735fad3d-f56d-4612-a4d9-854104d13923/tags"/>
    <domain id="72686576-2e6c-6162-2e65-6e672e627271" href="/api/domains/72686576-2e6c-6162-2e65-6e672e627271">
        <name>rhev.lab.eng.brq.redhat.com</name>
    </domain>
    <last_name>sapir</last_name>
    <user_name>osapir@rhev.lab.eng.brq.redhat.com</user_name>
    <groups>
        <group>
            <name>rhev.lab.eng.brq.redhat.com/QA-All-Users/RDP-Group</name>
        </group>
        <group>
            <name>rhev.lab.eng.brq.redhat.com/QA-All-Users/QA-MembersGroup</name>
        </group>
    </groups>
</user>

---
Comment 1 Yaniv Kaul 2012-04-18 04:13:53 EDT
regression?
Comment 2 Jaroslav Henner 2012-04-18 05:58:24 EDT
(In reply to comment #1)
> regression?

It looks like this was never tested. Therefore not a regression.
Comment 3 Ori Liel 2012-07-19 09:07:15 EDT
patch sent to gerrit: 

http://gerrit.ovirt.org/#/c/6458/
Comment 4 Ori Liel 2012-07-30 07:50:18 EDT
merged, commit c6917b32123a82963353cf3f7f9194af7e27cf11
Comment 5 Itamar Heim 2012-08-09 04:05:23 EDT
closing ON_QA bugs as oVirt 3.1 was released:
http://www.ovirt.org/get-ovirt/

Note You need to log in before you can comment on or make changes to this bug.