Bug 812047 - [abrt] libreoffice-core-3.4.5.2-10.fc16: __GI_exit: Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 6 (SIGABRT)
[abrt] libreoffice-core-3.4.5.2-10.fc16: __GI_exit: Process /usr/lib64/libreo...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:342548d5bf5a94a938c585ad609...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-12 11:42 EDT by Yann Droneaud
Modified: 2012-04-20 06:31 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-20 06:31:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (21.48 KB, text/plain)
2012-04-12 11:42 EDT, Yann Droneaud
no flags Details
File: maps (82.77 KB, text/plain)
2012-04-12 11:42 EDT, Yann Droneaud
no flags Details
File: backtrace (672.05 KB, text/plain)
2012-04-12 11:42 EDT, Yann Droneaud
no flags Details
valgrind log (7.87 KB, text/x-log)
2012-04-12 12:05 EDT, Yann Droneaud
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 48961 None None None Never

  None (edit)
Description Yann Droneaud 2012-04-12 11:42:24 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --impress ./rsockets-ofa12.pptx --splash-pipe=7
crash_function: __GI_exit
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.3.0-8.fc16.x86_64
pid:            666
pwd:            /home/ydroneaud
reason:         Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 6 (SIGABRT)
time:           jeu. 12 avril 2012 17:18:00 CEST
uid:            1000
username:       ydroneaud
var_log_messages: Apr 12 17:18:04 deela abrt[695]: Saved core dump of pid 666 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-04-12-17:18:00-666 (149602304 bytes)

backtrace:      Text file, 688180 bytes
dso_list:       Text file, 22000 bytes
maps:           Text file, 84761 bytes

comment:
:Ran SAL_SYNCHRONIZE=1 ooimpress ./rsockets-ofa12.pptx
:
:Started the presentation with F5, going from first slide up to the 20th.
:
:I got this message:
: 
:X-Error: BadAlloc (insufficient resources for operation)
:	Major opcode: 53 (X_CreatePixmap)
:	Resource ID:  0x3000b99
:	Serial No:    81954 (81954)
:Application Error
:
:Then Impress is stuck and I killed it with SIGABRT.
:
:Without SAL_SYNCHRONIZE=1, Impress quit at slide 20.
:
:The presentation file can be downloaded from https://www.openfabrics.org/downloads/rdmacm/rsockets-ofa12.pptx
:

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=3
:HOSTNAME=deela.quest-ce.net
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/tmp/keyring-7Zgn2g/gpg:0:1
:SHELL=/bin/bash
:TERM=xterm
:XDG_SESSION_COOKIE=4138bcffb25d83848820645a0000001a-1333621419.404547-1534886397
:HISTSIZE=1000
:GJS_DEBUG_OUTPUT=stderr
:CVSROOT=anoncvs@anoncvs.mindrot.org:/cvs
:WINDOWID=44040197
:OLDPWD=/usr/lib64/libreoffice/program
:GNOME_KEYRING_CONTROL=/tmp/keyring-7Zgn2g
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:IMSETTINGS_MODULE=none
:USER=ydroneaud
:LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:*.pdf=00;33:*.ps=00;33:*.ps.gz=00;33:*.txt=00;33:*.patch=00;33:*.diff=00;33:*.log=00;33:*.tex=00;33:*.xls=00;33:*.xlsx=00;33:*.ppt=00;33:*.pptx=00;33:*.rtf=00;33:*.doc=00;33:*.docx=00;33:*.odt=00;33:*.ods=00;33:*.odp=00;33:*.xml=00;33:*.epub=00;33:*.abw=00;33:*.html=00;33:*.wpd=00;33:
:SSH_AUTH_SOCK=/tmp/keyring-7Zgn2g/ssh
:USERNAME=ydroneaud
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1368,unix/unix:/tmp/.ICE-unix/1368
:DESKTOP_SESSION=gnome
:MAIL=/var/spool/mail/ydroneaud
:PATH=/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/ydroneaud/.local/bin:/home/ydroneaud/bin
:QT_IM_MODULE=xim
:PWD=/home/ydroneaud
:XMODIFIERS=@im=none
:SAL_SYNCHRONIZE=1
:LANG=fr_FR.UTF-8
:GNOME_KEYRING_PID=1360
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:SHLVL=2
:HOME=/home/ydroneaud
:XDG_SEAT=seat0
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SAL_ENABLE_FILE_LOCKING=1
:LOGNAME=ydroneaud
:CVS_RSH=/usr/bin/ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-bdc6S1cfT9,guid=6d37ca10d81877286f90436c00001315
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:DISPLAY=:0
:XDG_RUNTIME_DIR=/run/user/ydroneaud
:XAUTHORITY=/var/run/gdm/auth-for-ydroneaud-OLGhy2/database
:COLORTERM=gnome-terminal
:CCACHE_HASHDIR=
:LD_LIBRARY_PATH=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/client:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/server:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/native_threads:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64
Comment 1 Yann Droneaud 2012-04-12 11:42:28 EDT
Created attachment 577119 [details]
File: dso_list
Comment 2 Yann Droneaud 2012-04-12 11:42:30 EDT
Created attachment 577120 [details]
File: maps
Comment 3 Yann Droneaud 2012-04-12 11:42:34 EDT
Created attachment 577121 [details]
File: backtrace
Comment 4 Yann Droneaud 2012-04-12 12:05:54 EDT
Created attachment 577126 [details]
valgrind log

Here's a log produced with VALGRIND=memcheck SAL_SYNCHRONIZE=1 ooimpress ./rsockets-ofa12.pptx (sadly without libreoffice debug symbols)
Comment 5 Caolan McNamara 2012-04-18 10:13:41 EDT
#39 0x000000314962241a in XCreatePixmap (dpy=0x202e400, d=<optimized out>, width=187690, height=187580, depth=32) at CrPixmap.c:58

looks like the problem here, vast size -> XError, perhaps imported incorrectly earlier

Note You need to log in before you can comment on or make changes to this bug.