Bug 812052 - problem detecting sound hardware
problem detecting sound hardware
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-12 11:47 EDT by Lloyd Matthews
Modified: 2012-04-16 10:11 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-16 10:11:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"messages" for 3.3.1 kernel and 3.3.0 kernel boot (304.49 KB, text/plain)
2012-04-12 11:47 EDT, Lloyd Matthews
no flags Details

  None (edit)
Description Lloyd Matthews 2012-04-12 11:47:56 EDT
Created attachment 577122 [details]
"messages" for 3.3.1 kernel  and 3.3.0 kernel boot

Description of problem:
This started with kernel-PAE 3.3.1-3.  With all previous kernels for at least the past 1.5 years there have been no problems with sound hardware detection.  I boot up on 3.3.1 and log in to KDE and I get a KDE error pop up "Remove Sound Devices" that states that certain devices are no longer available and would I like to have them removed.  I also get a KDE notification balloon that states that HDA NVidia ALC883 does not work and it is falling back to "default".

Version-Release number of selected component (if applicable):
3.3.1-3

How reproducible:

Only one boot out of seven with 3.3.1-3 did not have the problem.  Every boot with < 3.3.1-3 works as expected.

Steps to Reproduce:
1.boot into kernel-PAE 3.3.1-3

  
Actual results:
receive messages that hardware needs to be removed.  If I boot enough times I did get the correct hardware, "Internal Audio Analog Stereo" one time.

Expected results:
boot into kernel-PAE 3.3.0-8
everything works as it should.  System Settings shows what it always shows: "Internal Audio Analog Stereo"


Additional info:
Fedora 16 upgraded from Fedora 14 (upgrade was back in December of 2011, no problems until latest kernel)
motherboard: ECS GeForce6100SM-M
Chipset: MCP61S
CPU: AMD Athlog 64 X2 5600+
nouveau driver on integrated Geforce6100 GPU

relevant sections of "messages" file for kernel-PAE 3.3.1-3 (Apr 11) and kernel-PAE 3.3.0-8 (Apr 12)
Comment 1 Josh Boyer 2012-04-12 12:46:08 EDT
The kernel seems to find the devices identically between kernel versions.  Both show the card0 probes working.

Pulseaudio seems to be having some kind of issue with having too many files open:

Apr 11 09:17:32 HAL5000 pulseaudio[2958]: module-udev-detect.c: inotify_init1() failed: Too many open files
Apr 11 09:17:32 HAL5000 pulseaudio[2958]: module.c: Failed to load  module "module-udev-detect" (argument: ""): initialization failed.
Apr 11 09:17:32 HAL5000 pulseaudio[2958]: main.c: Module load failed.
Apr 11 09:17:32 HAL5000 pulseaudio[2958]: main.c: Failed to initialize daemon.
Apr 11 09:17:32 HAL5000 pulseaudio[2956]: main.c: Daemon startup failed.

Lennart, what is pulseaudio trying to do there?

When you updated the kernel, was anything else updated at the same time?  Or have you done other updates since installing 3.3.0-8?  When kernel 3.3.1-3 was installed, it built a new initramfs to use with it.  If there were updates to things in userspace that are contained in the initramfs between the two kernel updates, then only the initramfs for 3.3.1-3 would contain those.

Also, can you please try 3.3.1-3 without loading the vbox modules at all?  While it may seem unrelated, they've been known to cause weird issues.
Comment 2 Lloyd Matthews 2012-04-12 16:19:20 EDT
Thank you for looking at this.  Of course, now that I have filed a bug, it figures that this time when I booted 3.3.0-8 that I just got the same message about the sound hardware.  So, it is NOT just 3.3.1-3.  It just appears to happen more often with 3.3.1-3 kernel.

As for what I updated the same time as the kernel:
perl-Try-Tiny-0.11-4
kdepim-4.8.1-4
ortp-0.20.0-2
libtasn1-2.12-1
clucene-core
libcdio-0.82-6
libffado-2.1.0-0.7.20111030.svn2000
taglib

I installed the 3.3.0-8 kernel back on April 2 and ran for the entire week, cold booting each morning with no problems.  So whatever it is seems to have crept in very recently.

I updated on April 4:
quazip-0.4.3-1
smplayer-0.7.1-1

I updated on April 3:
gnome-color-manager-3.2.3-1
folks-0.6.6-1
kdelibs-4.8.1-3
lohit-devanagari-fonts-2.5.1-2
yum-3.4.3-23


Now that 3.3.0-8 is acting up, I'm at a loss.  I am going to reinstall 3.3.1-3 and then see if I get the same problems with using Gnome instead of KDE.  I haven't tried Gnome since this started happening.
Comment 3 Lloyd Matthews 2012-04-12 16:43:38 EDT
I just installed 3.3.1-3 and rebooted (not a cold boot).  Then logged into my user account with Gnome DE.  No errors or messages.  Opened the system settings and then sound, everything looked as expected, and then I ran the sound test and it worked fine.  I then logged out of Gnome, and into KDE, no problem, and the sound settings in the KDE control panel were fine.  At this point, I think I need to run more tests with using Gnome vs KDE, to see if that really is an issue.

Best Regards
Comment 4 Lloyd Matthews 2012-04-16 09:52:25 EDT
I believe this can be closed.  I no longer believe it is a kernel problem.  It looks more like something with KDE on this system.  Consistently after a boot, if I log into Gnome first, then into KDE, there is no problem.  If I log straight into KDE, I have problems with the sound hardware detection, and some applications will not play sounds.
Comment 5 Josh Boyer 2012-04-16 10:11:39 EDT
Thank you for letting us know.

Note You need to log in before you can comment on or make changes to this bug.