Bug 812087 - remote-viewer can't connect to VNC display of anaconda at port 1
Summary: remote-viewer can't connect to VNC display of anaconda at port 1
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 6.3
Assignee: Daniel Berrangé
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-12 17:41 UTC by David Jaša
Modified: 2012-09-18 14:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-09-18 14:11:07 UTC
Target Upstream Version:


Attachments (Terms of Use)
anaconda tty screenshot (15.89 KB, image/png)
2012-04-13 08:18 UTC, David Jaša
no flags Details

Description David Jaša 2012-04-12 17:41:43 UTC
Description of problem:
remote-viewer can't connect to VNC display of anaconda at port 1

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-4.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. run anaconda with "vnc" kernel command line option
2. when anaconda says the IP and port, connect with remote-viewer:
remote-viewer vnc://<ip>/?port=<port>
  
Actual results:
remote-viewer does not connect with error dialog:
"Unable to connect to the graphic server vnc://<ip>/?port=<port>"

Expected results:
remote-viewer connects successfully

Additional info:
first and foremost, vncviewer connects successfully, so the problem is in virt-viewer

the outcome is the same when I try vnc://<ip>:<port>/

--debug output says this:
** (remote-viewer:15017): DEBUG: fullscreen display 0: 0
** (remote-viewer:15017): DEBUG: fullscreen display 0: 0
** (remote-viewer:15017): DEBUG: Opening display to vnc://10.34.58.168/?port=1
** (remote-viewer:15017): DEBUG: Guest vnc://10.34.58.168/?port=1 has a vnc display

** (remote-viewer:15017): DEBUG: After open connection callback fd=-1
** (remote-viewer:15017): DEBUG: Opening connection to display at vnc://10.34.58.168/?port=1

** (remote-viewer:15017): DEBUG: notebook show status 0x11a7070
** (remote-viewer:15017): DEBUG: Disconnected

and this after close of error dialog:
** (remote-viewer:15017): DEBUG: close vnc=0x1186520
** (remote-viewer:15017): DEBUG: notebook show status 0x11a7070
** (remote-viewer:15017): DEBUG: Guest vnc://10.34.58.168/?port=1 display has disconnected, shutting down
** (remote-viewer:15017): DEBUG: Set connect info: (null),(null),(null),-1,(null),(null),(null),0

Comment 1 Daniel Berrangé 2012-04-12 19:07:03 UTC
Please repeat with the '--gtk-vnc-debug' command line flag enabled too.

Comment 2 David Jaša 2012-04-13 08:18:56 UTC
Created attachment 577265 [details]
anaconda tty screenshot

The problem looks like a PEBKAC - partially. When I use vnc://10.34.58.168:5901/ remote viewer connects - but I have to realize, that:
1) by :1, both anaconda AND vncviewer mean :5901 (vncviewer :5901 also works)
2) for vnc:// uris, remote-viewer work with vnc://host:port/ only

(compare with spice, where only spice://host/?port=port work)

This sounds like the original bug can be splitted to three lesser-priority ones...

Comment 4 David Jaša 2012-04-27 08:35:09 UTC
Hi Zhe, the problem is that if you connect to e.g. vnc://10.34.58.168:1/ as specified by anaconda, connection fails because the server actually listens on port 5901.

Comment 6 RHEL Program Management 2012-07-10 06:58:50 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 7 RHEL Program Management 2012-07-11 02:00:58 UTC
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Comment 9 Daniel Berrangé 2012-09-18 14:11:07 UTC
This isn't a bug - it is just the syntax that remote-viewer expects for URIs


Note You need to log in before you can comment on or make changes to this bug.