Bug 812110 - [ipa webui] Delegation UI does not allow to specify permission
[ipa webui] Delegation UI does not allow to specify permission
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rob Crittenden
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-12 14:47 EDT by Namita Soman
Modified: 2012-06-20 09:27 EDT (History)
3 users (show)

See Also:
Fixed In Version: ipa-2.2.0-10.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:27:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Namita Soman 2012-04-12 14:47:14 EDT
Description of problem:
the CLI : ipa delegation-add allows 
--permissions=STR  Comma-separated list of permissions to grant (read,
                     write). Default is write.
But this is not available in UI

Version-Release number of selected component (if applicable):
ipa-server-2.2.0-8.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. Add a new Delegation

  
Actual results:
Cannot specify permission

Expected results:
To be able to specify permission

Additional info:
Comment 2 Martin Kosek 2012-04-13 04:18:12 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/2635
Comment 3 Rob Crittenden 2012-04-18 11:03:51 EDT
Fixed upstream. Added check boxes for permissions.

master: 7f2ac4c71594f4895d949faffeb15562b1f5fa33

ipa-2-2: d27b55c0c721516ceda26aedabe14f8ea0a3dadd
Comment 6 Petr Vobornik 2012-04-26 09:33:19 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed.
Comment 7 Namita Soman 2012-04-30 15:31:59 EDT
Verified using ipa-server-2.2.0-11.el6.x86_64
Can specify permissions for read/write
Comment 9 errata-xmlrpc 2012-06-20 09:27:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0819.html

Note You need to log in before you can comment on or make changes to this bug.