Bug 812114 - package install failure with php53 packages due to Requires: on php version
package install failure with php53 packages due to Requires: on php version
Status: CLOSED WONTFIX
Product: Fedora EPEL
Classification: Fedora
Component: php-pear-HTTP (Show other bugs)
el5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-12 14:56 EDT by Jason Corley
Modified: 2012-04-14 01:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-14 01:29:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Corley 2012-04-12 14:56:58 EDT
Description of problem:

the php53 package from RHEL 5.8 does not provide php so the following line:
  Requires: php >= 4.0.6
means php-pear-HTTP cannot be installed with the php53 packages installed.

Version-Release number of selected component (if applicable):
1.4.0-7.el5

How reproducible:
100%

Steps to Reproduce:
1. install php53 packages
2. try to install php-pear-HTTP
3. see failure
  
Actual results:
$ rpm -qa php53\* --pipe="LANG=C sort"
php53-5.3.3-5.el5
php53-cli-5.3.3-5.el5
php53-common-5.3.3-5.el5
php53-devel-5.3.3-5.el5
php53-mcrypt-5.3.3-1.el5
php53-mysql-5.3.3-5.el5
php53-pdo-5.3.3-5.el5
php53-xml-5.3.3-5.el5
$ yum install php-pear-HTTP
Loaded plugins: downloadonly, fastestmirror, priorities
You need to be root to perform this command.
[jasonc@localhost ~]$ sudo !!
sudo yum install php-pear-HTTP
Loaded plugins: downloadonly, fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * base: mirrors.gigenet.com
 * epel: ftp.osuosl.org
 * extras: mirrors.gigenet.com
 * updates: mirror.us.leaseweb.net
245 packages excluded due to repository priority protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-pear-HTTP.noarch 0:1.4.0-7.el5 set to be updated
--> Processing Dependency: php >= 4.0.6 for package: php-pear-HTTP
--> Running transaction check
---> Package php.x86_64 0:5.1.6-32.el5 set to be updated
--> Processing Dependency: php-common = 5.1.6-32.el5 for package: php
--> Processing Dependency: php-cli = 5.1.6-32.el5 for package: php
--> Running transaction check
---> Package php-cli.x86_64 0:5.1.6-32.el5 set to be updated
---> Package php-common.x86_64 0:5.1.6-32.el5 set to be updated
--> Processing Conflict: php53-common conflicts php-common
--> Finished Dependency Resolution
php53-common-5.3.3-5.el5.x86_64 from installed has depsolving problems
  --> php53-common conflicts with php-common
Error: php53-common conflicts with php-common
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

Expected results:
package should install
Comment 1 Remi Collet 2012-04-14 01:29:00 EDT
This package is designed to work with stock php 5.1.6, not with php53

So you need php53-pear-* pakages (which doesn't exist)

I don't plan any fix for this.

Note You need to log in before you can comment on or make changes to this bug.