Bug 812153 - release command should have a --show option which is the default
release command should have a --show option which is the default
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: William Poteat
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-04-12 18:16 EDT by Bryan Kearney
Modified: 2013-01-07 22:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:50:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Kearney 2012-04-12 18:16:05 EDT
The defailt action for release is to show the current release. With other commands, we do this by having a -- sub command and listing it as default.

Please add the --show command and note in the help that this is the default.
Comment 1 RHEL Product and Program Management 2012-04-16 22:08:51 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 William Poteat 2012-05-14 13:21:25 EDT
master commit e2f3f590df844a9bee23dc7d4ac284ff61fd1ca3
Comment 3 J.C. Molet 2012-06-19 12:22:13 EDT
Tested on:

subscription-manager-1.0.4-1.git.3.1768f90.el5

[root@jmolet-vm0 ~]# diff <(subscription-manager release) <(subscription-manager release --show)
[root@jmolet-vm0 ~]# 
#no output
[root@jmolet-vm0 ~]# subscription-manager release
Release not set

subscription-manager release and release --show do the same thing now.

marking VERIFIED.
Comment 6 errata-xmlrpc 2013-01-07 22:50:32 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.