Bug 812168 - VESA driver loaded for Intel ICH9 chipset
VESA driver loaded for Intel ICH9 chipset
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-12 20:03 EDT by Joerg Skottke
Modified: 2012-04-13 07:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-13 07:15:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X.org content (84.98 KB, text/x-log)
2012-04-12 20:03 EDT, Joerg Skottke
no flags Details
dmesg content (61.16 KB, text/plain)
2012-04-12 20:06 EDT, Joerg Skottke
no flags Details

  None (edit)
Description Joerg Skottke 2012-04-12 20:03:12 EDT
Created attachment 577192 [details]
X.org content

Description of problem:
Fedora 17 loads the wrong display driver for the integrated Intel ICH9 chipset:
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)


Version-Release number of selected component (if applicable):


How reproducible:
Install F17 on (probably) any Notebook using this chipset


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Joerg Skottke 2012-04-12 20:04:53 EDT
Satting regression keyword, this works perfectly on F16 on the same hardware
Comment 2 Joerg Skottke 2012-04-12 20:06:19 EDT
Created attachment 577193 [details]
dmesg content
Comment 3 Joerg Skottke 2012-04-12 21:10:50 EDT
After playing around with the kernel boot options i found that removing the option "nomodeset" fixes the problem.

Changing this in /etc/default/grub seems to be a usable workaround.
Comment 4 Dave Airlie 2012-04-13 07:15:08 EDT
we don't add nomodeset unless you do something to make it get added.

Note You need to log in before you can comment on or make changes to this bug.