Bug 812192 - kernel-2.6.32-220.el6.x86_64 missing /sbin/new-kernel-pkg
kernel-2.6.32-220.el6.x86_64 missing /sbin/new-kernel-pkg
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: grubby (Show other bugs)
6.2
x86_64 Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Peter Jones
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-12 22:39 EDT by Kevin Burrus
Modified: 2012-07-12 14:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-12 14:35:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Burrus 2012-04-12 22:39:03 EDT
Description of problem:
In Yum Extender, I get the following error: 21:31:35 : ERROR: Error in yum Transaction : [u'ERROR with rpm_check_debug vs depsolve:', '/sbin/new-kernel-pkg is needed by (installed) kernel-2.6.32-220.el6.x86_64', '/sbin/new-kernel-pkg is needed by (installed) kernel-2.6.32-220.el6.x86_64', u'Please report this error at https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%206&component=yum']

Version-Release number of selected component (if applicable): el 6.2


How reproducible: If you try to install kernel-2.6.32-220.el6.x86_64 you should receive this error


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Prarit Bhargava 2012-04-16 08:55:38 EDT
Hi Kevin,

Thanks for the bug report.  Could you please let me know what your _original_ kernel version was?  I'd like to try reproducing it here using exactly the kernel versions you are/were using.

Thanks,

P.
Comment 3 Prarit Bhargava 2012-04-23 14:28:15 EDT
/sbin/new-kernel-pkg is from grubby, not the kernel.
Comment 4 RHEL Product and Program Management 2012-05-03 01:18:22 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 5 Peter Jones 2012-07-12 14:35:05 EDT
This appears to me to be a bug in Yum Extender, which we don't ship. At any rate it's certainly not a grubby bug. I'm closing this, as I don't think it's our bug.  If there's data which shows that I'm wrong, feel free to re-open it.

Note You need to log in before you can comment on or make changes to this bug.