Bug 812233 - Make e-mail notification plain text by default
Make e-mail notification plain text by default
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Email Notifications (Show other bugs)
4.2
Unspecified Unspecified
urgent Severity urgent (vote)
: ---
: ---
Assigned To: Simon Green
: Reopened
: 823517 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-13 04:08 EDT by Petr Pisar
Modified: 2014-10-12 18:47 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-21 10:19:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2012-04-13 04:08:43 EDT
Bugzilla 4.2 release notes highlights e-mail notifications will be sent in HTML format by default. Current <https://partner-bugzilla.redhat.com/userprefs.cgi?tab=settings> Red Hat Bugzilla testing instance confirms it.

I personally prefer plain text e-mails. I think most of the developers either.

So I propose the change default settings to plain text notifications.
Comment 1 Simon Green 2012-04-13 04:32:47 EDT
You are free to change it to plain text yourself (Bugzilla->Preferences), or specify it in your mail client. The e-mail is sent with the multipart/alternative content type.

However, HTML e-mails will be the default.

  -- simon
Comment 2 Tomas Mraz 2012-05-21 02:29:48 EDT
This is breaking the principle of least surprise - at least the default should not have been changed for existing users after the upgrade.
Comment 3 Miroslav Vadkerti 2012-05-21 03:52:01 EDT
The same for the crazy comment box before comments!
Comment 4 Peter Martuccelli 2012-05-21 09:23:24 EDT
Reopening as plain text should remain the default for all development accounts. Breaking engineering workflows is not acceptable.
Comment 5 Simon Green 2012-05-21 09:25:07 EDT
See comment #1.
Comment 6 Simon Green 2012-05-21 09:26:24 EDT
*** Bug 823517 has been marked as a duplicate of this bug. ***
Comment 7 Prarit Bhargava 2012-05-21 09:27:59 EDT
I agree with peterm here:  If you're going to make a publicly visible change you should have indicated that this change was coming in the Bugzilla Update emails that were sent out, AND included instructions how to change it back to the previous default of text-only email.

P.
Comment 8 Neil Horman 2012-05-21 10:18:04 EDT
Telling users that they can change it back isn't sufficient.

More than humans use Bugzilla.  If bugbots/email parsers/automated tools expect plain text, changing the default on those tools will break them, and if a human isn't monitoring those tools, they're all going to have to track this problem down.  You need to change this back and make html email opt in, at least until such time as you can announce the deprecation of the text default in favor of HTML, and give users a chance to react to the change.
Comment 9 Kay Sievers 2012-05-21 10:23:55 EDT
Also, not all bug assignees are humans but lists. These lists now get HTML,
and I have no idea really how to log into these list accounts and change the
stuff back to what it was.
Comment 10 Stefan Assmann 2012-05-21 10:26:05 EDT
Simon,
please listen to us. This change makes life difficult for 99% of engineers and breaks lots of tools. What is the reason that you are unwilling to switch the default back to what it was before?
Comment 11 Adam Jackson 2012-05-21 11:52:33 EDT
(In reply to comment #5)
> See comment #1.

I assume we're meant to read that as in "see figure one".
Comment 12 Jeff Garzik 2012-05-21 15:01:21 EDT
This impacts me also, as my primary source of bugzilla emails is mutt MUA.
Comment 13 Kevin Baker 2012-05-21 16:53:20 EDT
(In reply to comment #9)
> Also, not all bug assignees are humans but lists. These lists now get HTML,
> and I have no idea really how to log into these list accounts and change the
> stuff back to what it was.

If you supply the list names we can configure them as plain only. I did that for kernel-mgr@redhat.com

Kev
Comment 14 Panu Matilainen 2012-05-22 08:11:42 EDT
(In reply to comment #13)
> If you supply the list names we can configure them as plain only. I did that
> for kernel-mgr@redhat.com

Why not just switch the default back to non-html instead of forcing everybody including yourselves jump through hoops because of this unexplained and strange change of defaults? If somebody wants html goo in their mail they'd still have the option to have it, but I'm willing to bet most of us dealing with bugzilla believe html belongs to web pages, not email.
Comment 15 Simon Green 2012-05-22 20:57:36 EDT
(In reply to comment #14)
> (In reply to comment #13)
> > If you supply the list names we can configure them as plain only. I did that
> > for kernel-mgr@redhat.com
> 
> Why not just switch the default back to non-html instead of forcing
> everybody including yourselves jump through hoops because of this
> unexplained and strange change of defaults? 

As of midnight UTC, text e-mail and additional comment below comments are the defaults.

  -- simon
Comment 16 Panu Matilainen 2012-05-23 01:22:26 EDT
(In reply to comment #15)
> As of midnight UTC, text e-mail and additional comment below comments are
> the defaults.

Ah... sanity :) Thank you!

Note You need to log in before you can comment on or make changes to this bug.