Bug 812300 - A rare condition can lead to fail to recv
A rare condition can lead to fail to recv
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openais (Show other bugs)
5.9
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Jan Friesse
Cluster QE
: ZStream
Depends On: 806901
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-13 06:33 EDT by RHEL Product and Program Management
Modified: 2012-08-10 08:09 EDT (History)
8 users (show)

See Also:
Fixed In Version: openais-0.80.6-28.el5_6.5
Doc Type: Bug Fix
Doc Text:
OpenIAS previously performed the incorrect test of the message ID range in the update_aru() function. This could cause OpenAIS to fail to receive multicast packet transmissions with the "FAILED TO RECEIVE" error message. This update removes the incorrect test so that OpenAIS no longer fails in this scenario, and proper checks of the message ID range are performed using the fail_to_recv_const constant.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-10 02:38:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
5.6.z-revision-2189 (359 bytes, patch)
2012-04-24 03:46 EDT, Jan Friesse
no flags Details | Diff

  None (edit)
Description RHEL Product and Program Management 2012-04-13 06:33:01 EDT
This bug has been copied from bug #806901 and has been proposed
to be backported to 5.6 z-stream (EUS).
Comment 4 Jan Friesse 2012-04-24 03:46:15 EDT
Created attachment 579776 [details]
5.6.z-revision-2189
Comment 7 Miroslav Svoboda 2012-04-30 18:55:24 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
OpenIAS previously performed the incorrect test of the message ID range in the update_aru() function. This could cause OpenAIS to fail to receive multicast packet transmissions with the "FAILED TO RECEIVE" error message. This update removes the incorrect test so that OpenAIS no longer fails in this scenario, and proper checks of the message ID range are performed using the fail_to_recv_const constant.
Comment 8 errata-xmlrpc 2012-05-10 02:38:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0559.html

Note You need to log in before you can comment on or make changes to this bug.