Bug 812309 - DP is not recognized on SandyBridge
DP is not recognized on SandyBridge
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Dave Airlie
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-13 06:51 EDT by Tomas Pelka
Modified: 2015-11-10 13:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-10 13:17:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xrandr output (5.14 KB, text/plain)
2012-04-13 06:52 EDT, Tomas Pelka
no flags Details
xorg log (117.55 KB, text/plain)
2012-04-13 06:53 EDT, Tomas Pelka
no flags Details
dmesg (81.98 KB, text/plain)
2012-04-13 06:53 EDT, Tomas Pelka
no flags Details

  None (edit)
Description Tomas Pelka 2012-04-13 06:51:28 EDT
Description of problem:
Intel driver is not able to recognize DP.

Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.16.0-1.el6
kernel-2.6.32-259.el6
xorg-x11-server-Xorg-1.10.6-1.el6
xorg-x11-drv-nouveau-0.0.16-13.20110719gitde9d1ba.el6


How reproducible:
100%

Steps to Reproduce:
1. boot system with only Intel enabled
2. try to connect monitor to DP
3.
  
Actual results:
no output

Expected results:
not sure if it should be enabled or shared between two graphics

Additional info:
nor ALSA is not able to recognize audio output for it

this system have two graphics, Intel and discrete Nvidia. Discrete graphic is disabled in BIOS
Comment 1 Tomas Pelka 2012-04-13 06:52:37 EDT
Created attachment 577296 [details]
xrandr output
Comment 2 Tomas Pelka 2012-04-13 06:53:08 EDT
Created attachment 577297 [details]
xorg log
Comment 3 Tomas Pelka 2012-04-13 06:53:57 EDT
Created attachment 577298 [details]
dmesg
Comment 4 Tomas Pelka 2012-04-13 07:10:48 EDT
When discrete card enabled than system can see the DP out, but I'm not able to detect a monitor in g-d-p.

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF119 [Quadro NVS 4200M] [10de:1057] (rev a1) (prog-if 00 [VGA controller])
	Subsystem: Lenovo Device [17aa:21cf]
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at f2000000 (32-bit, non-prefetchable) [size=16M]
	Memory at e0000000 (64-bit, prefetchable) [size=256M]
	Memory at f0000000 (64-bit, prefetchable) [size=32M]
	I/O ports at 5000 [size=128]
	Expansion ROM at f3080000 [disabled] [size=512K]
	Capabilities: <access denied>
	Kernel driver in use: nouveau
	Kernel modules: nouveau, nvidiafb
Comment 5 Tomas Pelka 2012-04-13 07:11:21 EDT
Just note that VGA works fine.
Comment 6 Tomas Pelka 2012-04-13 07:21:43 EDT
Info about Intel:

00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
	Subsystem: Lenovo Device [17aa:21d1]
	Flags: bus master, fast devsel, latency 0, IRQ 24
	Memory at f0000000 (64-bit, non-prefetchable) [size=4M]
	Memory at e0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at 5000 [size=64]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: <access denied>
	Kernel driver in use: i915
	Kernel modules: i915
Comment 7 Adam Jackson 2012-04-17 14:48:15 EDT
Yeah, that's going to not work.  GPU-switching setups like that simply don't wire the DP (or any external digital port in fact) to the Intel chip.

Moving to 6.4, we might have prime support in working shape by then.
Comment 8 Adam Jackson 2012-04-17 14:48:34 EDT
Fix assignee.
Comment 9 RHEL Product and Program Management 2012-07-10 04:54:56 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 10 RHEL Product and Program Management 2012-07-10 19:36:20 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 11 RHEL Product and Program Management 2012-12-14 03:52:13 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 12 Lyude 2015-11-06 17:46:43 EST
Still present in 6.7, also reproduced using an upstream kernel.
Comment 13 Dave Airlie 2015-11-09 15:10:51 EST
If you disable the NVIDIA nothing is connected to the displayport port as there is no mux on that.

So it's working as designed AFAICS, even if designed is broken.
Comment 14 Lyude 2015-11-10 13:17:12 EST
originally kept this open because I could reproduce the issue on the nvidia card, however upon further inspection it turns out two of our mini displayport to displayport adaptors were actually broken, and using a third one fixed the problem. Closing

Note You need to log in before you can comment on or make changes to this bug.