This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 812432 - kernel 2.6.18-308.1.1.el5 causes certain nfs directories to be inaccessible. [NEEDINFO]
kernel 2.6.18-308.1.1.el5 causes certain nfs directories to be inaccessible.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.8
x86_64 Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-13 13:23 EDT by Thomas Uphill
Modified: 2014-06-03 08:26 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-03 08:26:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (tuphill)


Attachments (Terms of Use)

  None (edit)
Description Thomas Uphill 2012-04-13 13:23:50 EDT
Description of problem:

upgrading to latest kernel (2.6.18-308.1.1.el5) broke access to .snapshot directories mounted from a network appliance filer.  Downgrading to previous version (2.6.18-274.18.1.el5) fixes the issue.

Version-Release number of selected component (if applicable):

kernel-2.6.18-308.1.1.el5

How reproducible:

Always

Steps to Reproduce:
1.boot into 2.6.18-308.1.1.el5
2.ls -a mountpoint/.snapshot
3.cd mountpoint/.snapshot
  
Actual results:
[thomas@admin: ~] $ uname -r
2.6.18-308.1.1.el5
[thomas@admin: ~] $ ls -ld /mnt/storage/.snapshot
drwxrwxrwx 42 root root 4096 Apr 13 12:07 /mnt/storage/.snapshot
[thomas@admin: ~] $ cd /mnt/storage/.snapshot
-bash: cd: /mnt/storage/.snapshot: Not a directory

Expected results:
[thomas@admin: ~] $ uname -r
2.6.18-274.18.1.el5
[thomas@admin: ~] $ ls -ld /mnt/storage/.snapshot
drwxrwxrwx 42 root root 4096 Apr 13 13:09 /mnt/storage/.snapshot
[thomas@admin: ~] $ ls -l /mnt/storage/.snapshot
total 160
drwxr-xr-x 19 root root 4096 Mar  7 00:04 sv_daily.0
drwxr-xr-x 19 root root 4096 Mar  7 00:04 sv_daily.1
drwxr-xr-x 19 root root 4096 Mar  7 00:04 sv_daily.10
drwxr-xr-x 19 root root 4096 Mar  7 00:04 sv_daily.11
...

Additional info:
ontap version is NetApp Release 8.0 7-Mode: Thu Mar 11 16:17:13 PST 2010

from working kernel:
[thomas@admin: ~] $ stat /mnt/storage/.snapshot
  File: `/mnt/storage/.snapshot'
  Size: 4096      	Blocks: 8          IO Block: 8192   directory
Device: 1eh/30d	Inode: 67          Links: 42
Access: (0777/drwxrwxrwx)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2008-07-17 13:43:56.792986000 -0400
Modify: 2012-04-13 13:09:00.855850000 -0400
Change: 2012-04-13 13:09:00.855850000 -0400

from latest kernel:
[thomas@admin: ~] $ stat /mnt/storage/.snapshot
  File: `/mnt/storage/.snapshot'
  Size: 4096      	Blocks: 8          IO Block: 8192   directory
Device: 19h/25d	Inode: 67          Links: 42
Access: (0777/drwxrwxrwx)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2008-07-17 13:43:56.792986000 -0400
Modify: 2012-04-13 13:09:00.855850000 -0400
Change: 2012-04-13 13:09:00.855850000 -0400
[thomas@admin: ~] $ stat /mnt/storage/.snapshot/.
stat: cannot stat `/mnt/storage/.snapshot/.': Not a directory
Comment 1 Judd Tracy 2012-04-18 13:21:15 EDT
I am experiencing the same problem with kernel-2.6.18-308.1.1.el5 except I am serving them from a RHEL nfs server using NFS4 and tcp.

Some of the nfs mounts work but most of them do not.

Here are how some of the exports are setup.

/export X.X.X.X/24(rw,fsid=0,no_subtree_check)
/export/home    X.X.X.X/24(rw,fsid=____,no_subtree_check,nohide,secure)
/export/dir1/dir2/dir3/filestore    X.X.X.X(rw,fsid=____,no_subtree_check,nohide)


Mounting nfsserver:/home/<username> works fine using autofs

We have nfsserver:/export/dir1 mounted on the client and trying to access exports under this mount point causes the "Not a directory" error on the client.
Comment 2 RHEL Product and Program Management 2014-03-07 07:38:36 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 3 RHEL Product and Program Management 2014-06-03 08:26:12 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.