This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 812447 - chown fails on nfs4 mounted files for new users
chown fails on nfs4 mounted files for new users
Status: CLOSED DUPLICATE of bug 849945
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils (Show other bugs)
6.3
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Steve Dickson
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-13 14:42 EDT by Alejandro Ramirez
Modified: 2012-10-08 08:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-08 08:44:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
strace output of chown command (8.58 KB, text/plain)
2012-04-13 14:42 EDT, Alejandro Ramirez
no flags Details

  None (edit)
Description Alejandro Ramirez 2012-04-13 14:42:24 EDT
Created attachment 577400 [details]
strace output of chown command

Description of problem:
When issuing a chown syscall on a NFSv4 mounted file or directory for a newly created LDAP user, I get an "Invalid argument".  The chown will fail until the user is about 10 minutes old which makes me think it is some kind of caching issue in NFS.  If I mount with vers=3, this error does not occur.  
When I su as the new user, I can create files and directories on the NFSv4 mount and they will have the correct user and group but when I issue a chown command on the new file, it will fail with invalid argument, even if I put the same user and group the file already has.  Again, give it 10 minutes and everything works perfect.

Version-Release number of selected component (if applicable):
nfs-utils-1.2.3-15.el6.x86_64

How reproducible:
Can be reproduced with every new user created.

Steps to Reproduce:
1.  Have an NFS server to serve home directories.
2.  Have LDAP servers for user management.
3.  Create a new user with a script on the LDAP server:
        a.  Add user to LDAP database.
        b.  Create home directory structure on NFSv4 mount.
        c.  Copy skel files to new home directory.
        d.  Chown all contents of home directory
            Fails with Invalid Argument.
  
Actual results:
File permissions do not get updated

Expected results:
File permissions should get updated.

Additional info:
Root is not squashed on the LDAP server.
idmapd is running correctly mapping uid and gid's.
Attaching strace output.
Let me know if you need any additional info or testing on my part.
Comment 2 RHEL Product and Program Management 2012-05-03 01:14:53 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 3 Alejandro Ramirez 2012-06-26 10:34:44 EDT
Still a bug in 6.3.
Comment 4 Steve Dickson 2012-10-08 08:44:12 EDT

*** This bug has been marked as a duplicate of bug 849945 ***

Note You need to log in before you can comment on or make changes to this bug.