Bug 812467 - SELinux is preventing /sbin/setfiles from 'associate' accesses on the Dateisystem /etc/shells.
SELinux is preventing /sbin/setfiles from 'associate' accesses on the Dateisy...
Status: CLOSED DUPLICATE of bug 812464
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:1a9e90209b03958376484fb5275...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-13 15:52 EDT by autarch princeps
Modified: 2012-04-13 16:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-13 16:17:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description autarch princeps 2012-04-13 15:52:49 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.1-3.fc16.x86_64
reason:         SELinux is preventing /sbin/setfiles from 'associate' accesses on the Dateisystem /etc/shells.
time:           Fr 13 Apr 2012 21:52:36 CEST

description:
:SELinux is preventing /sbin/setfiles from 'associate' accesses on the Dateisystem /etc/shells.
:
:*****  Plugin filesystem_associate (99.5 confidence) suggests  ***************
:
:If you believe setfiles should be allowed to create shells files
:Then you need to use a different command. You are not allowed to preserve the SELinux context on the target file system.
:Do
:use a command like "cp -p" to preserve all permissions except SELinux context.
:
:*****  Plugin catchall (1.49 confidence) suggests  ***************************
:
:If you believe that setfiles should be allowed associate access on the shells filesystem by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep restorecon /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:object_r:ldconfig_t:s0
:Target Context                system_u:object_r:fs_t:s0
:Target Objects                /etc/shells [ filesystem ]
:Source                        restorecon
:Source Path                   /sbin/setfiles
:Port                          <Unbekannt>
:Host                          (removed)
:Source RPM Packages           policycoreutils-2.1.4-13.fc16.x86_64
:Target RPM Packages           setup-2.8.36-3.fc16.noarch
:Policy RPM                    selinux-policy-3.10.0-80.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.1-3.fc16.x86_64 #1 SMP
:                              Wed Apr 4 18:08:51 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    Fr 13 Apr 2012 21:50:55 CEST
:Last Seen                     Fr 13 Apr 2012 21:51:35 CEST
:Local ID                      a0568463-e159-4424-8bb2-9a8d91071e7d
:
:Raw Audit Messages
:type=AVC msg=audit(1334346695.916:201): avc:  denied  { associate } for  pid=15186 comm="restorecon" name="shells" dev="sda3" ino=131625 scontext=system_u:object_r:ldconfig_t:s0 tcontext=system_u:object_r:fs_t:s0 tclass=filesystem
:
:
:type=SYSCALL msg=audit(1334346695.916:201): arch=x86_64 syscall=lsetxattr success=no exit=EACCES a0=7f57e1f76e00 a1=7f57dfc3d46b a2=7f57e1e42410 a3=20 items=0 ppid=15185 pid=15186 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=restorecon exe=/sbin/setfiles subj=system_u:system_r:setfiles_t:s0-s0:c0.c1023 key=(null)
:
:Hash: restorecon,ldconfig_t,fs_t,filesystem,associate
:
:audit2allow
:
:#============= ldconfig_t ==============
:allow ldconfig_t fs_t:filesystem associate;
:
:audit2allow -R
:
:#============= ldconfig_t ==============
:allow ldconfig_t fs_t:filesystem associate;
:
Comment 1 Daniel Walsh 2012-04-13 16:17:52 EDT

*** This bug has been marked as a duplicate of bug 812464 ***

Note You need to log in before you can comment on or make changes to this bug.