Bug 812483 - [fr_FR] [ru_RU] [bn_IN] [kn_IN] [ta_IN] "Product ID:" is not translated.
[fr_FR] [ru_RU] [bn_IN] [kn_IN] [ta_IN] "Product ID:" is not translated.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: candlepin-bugs
Entitlement Bugs
: Translation
Depends On:
Blocks: 771481
  Show dependency treegraph
 
Reported: 2012-04-13 17:06 EDT by John Sefler
Modified: 2013-02-21 03:54 EST (History)
6 users (show)

See Also:
Fixed In Version: subscription-manager-1.1.6-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:54:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-04-13 17:06:30 EDT
Description of problem:
Follow-on from Bug 807022 for needed translations for languages:

fr  - missing msgid "<b>Product ID:</b>"
pt  - "Product ID:" is not translated; skipped?  Expected "ID do Produto:"
ru  - missing msgid "<b>Product ID:</b>"
bn  - missing msgid "<b>Product ID:</b>"
kn  - missing msgid "<b>Product ID:</b>"
ta  - missing msgid "<b>Product ID:</b>"


Version-Release number of selected component (if applicable):
[root@jsefler-r63-server ~]# rpm -q subscription-manager
subscription-manager-0.99.14-1.el6.x86_64


How reproducible:


Steps to Reproduce:
[root@jsefler-r63-server ~]# for L in de es fr it ja ko pt ru zh_CN as bn hi mr gu kn ml or pa ta te; do echo ""; echo "LOOKING FOR 'Product ID' TRANSLATION IN LANG $L.............."; msgunfmt /usr/share/locale/$L/LC_MESSAGES/rhsm.mo | grep -i 'Product ID:' -A1; done;

  
Actual results:


Expected results:
Expected a msgid hit on "Product ID" for all languages

Additional info:
Comment 1 John Sefler 2012-04-13 17:34:05 EDT
I don't know why the msgid's are missing from the rhsm.mo files, but if they are not in the rhsm.mo files, then they can't possibly be translated by the translators.
Comment 4 RHEL Product and Program Management 2012-07-10 04:47:41 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2012-07-10 21:49:00 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 6 Adrian Likins 2012-11-09 15:59:45 EST
This seems to be in every po file now, with a translation.
Comment 8 John Sefler 2012-12-21 13:27:15 EST
Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.18-1.el6.x86_64


[root@jsefler-6 ~]# for L in `rpm -ql subscription-manager | grep rhsm.mo`; do echo ""; echo "LOOKING FOR MSGID 'Product ID:' IN LANG FILE $L..."; msgunfmt $L | grep -i 'Product ID:' -A1; done;

LOOKING FOR MSGID 'Product ID:' IN LANG FILE /usr/share/locale/as/LC_MESSAGES/rhsm.mo...
msgid "Product ID:           \t%s"
msgstr "উৎপাদন ID:           \t%s"

LOOKING FOR MSGID 'Product ID:' IN LANG FILE /usr/share/locale/bn_IN/LC_MESSAGES/rhsm.mo...
msgid "Product ID:           \t%s"
msgstr "উৎপাদনের ID:           \t%s"

LOOKING FOR MSGID 'Product ID:' IN LANG FILE /usr/share/locale/de_DE/LC_MESSAGES/rhsm.mo...
msgid "Product ID:           \t%s"
msgstr "Produkt-ID:           \t%s"

LOOKING FOR MSGID 'Product ID:' IN LANG FILE /usr/share/locale/es_ES/LC_MESSAGES/rhsm.mo...
msgid "Product ID:           \t%s"
msgstr "ID de producto:  \t%s"

LOOKING FOR MSGID 'Product ID:' IN LANG FILE /usr/share/locale/fr/LC_MESSAGES/rhsm.mo...
msgid "Product ID:           \t%s"
msgstr "ID du produit :           \t%s"

LOOKING FOR MSGID 'Product ID:' IN LANG FILE /usr/share/locale/gu/LC_MESSAGES/rhsm.mo...
msgid "Product ID:           \t%s"
msgstr "પ્રોડક્ટ ID:           \t%s"

LOOKING FOR MSGID 'Product ID:' IN LANG FILE /usr/share/locale/hi/LC_MESSAGES/rhsm.mo...
msgid "Product ID:           \t%s"
msgstr "उत्पाद ID:           \t%s"

LOOKING FOR MSGID 'Product ID:' IN LANG FILE /usr/share/locale/it/LC_MESSAGES/rhsm.mo...
msgid "Product ID:           \t%s"
msgstr "ID del prodotto:           \t%s"

LOOKING FOR MSGID 'Product ID:' IN LANG FILE /usr/share/locale/ja/LC_MESSAGES/rhsm.mo...
msgid "Product ID:           \t%s"
msgstr "製品 ID:           \t%s"

LOOKING FOR MSGID 'Product ID:' IN LANG FILE /usr/share/locale/kn/LC_MESSAGES/rhsm.mo...
msgid "Product ID:           \t%s"
msgstr "ಉತ್ಪನ್ನ ID:           \t%s"

LOOKING FOR MSGID 'Product ID:' IN LANG FILE /usr/share/locale/ko/LC_MESSAGES/rhsm.mo...
msgid "Product ID:           \t%s"
msgstr "제품 ID:           \t%s"

LOOKING FOR MSGID 'Product ID:' IN LANG FILE /usr/share/locale/ml/LC_MESSAGES/rhsm.mo...
msgid "Product ID:           \t%s"
msgstr "പ്രൊഡക്ട് ഐഡി: %s"

LOOKING FOR MSGID 'Product ID:' IN LANG FILE /usr/share/locale/mr/LC_MESSAGES/rhsm.mo...
msgid "Product ID:           \t%s"
msgstr "उत्पादन ID:           \t%s"

LOOKING FOR MSGID 'Product ID:' IN LANG FILE /usr/share/locale/or/LC_MESSAGES/rhsm.mo...
msgid "Product ID:           \t%s"
msgstr "ଉତ୍ପାଦନ ID:           \t%s"

LOOKING FOR MSGID 'Product ID:' IN LANG FILE /usr/share/locale/pa/LC_MESSAGES/rhsm.mo...
msgid "Product ID:           \t%s"
msgstr "ਉਤਪਾਦ ID:           \t%s"

LOOKING FOR MSGID 'Product ID:' IN LANG FILE /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.mo...
msgid "Product ID:           \t%s"
msgstr "ID do Produto: %s"

LOOKING FOR MSGID 'Product ID:' IN LANG FILE /usr/share/locale/ru/LC_MESSAGES/rhsm.mo...
msgid "Product ID:           \t%s"
msgstr "ID продукта:           \t%s"

LOOKING FOR MSGID 'Product ID:' IN LANG FILE /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.mo...
msgid "Product ID:           \t%s"
msgstr "தயாரிப்பின் ID:           \t%s"

LOOKING FOR MSGID 'Product ID:' IN LANG FILE /usr/share/locale/te/LC_MESSAGES/rhsm.mo...
msgid "Product ID:           \t%s"
msgstr "ఉత్పత్తి ఐడి:\t%s"

LOOKING FOR MSGID 'Product ID:' IN LANG FILE /usr/share/locale/zh_CN/LC_MESSAGES/rhsm.mo...
msgid "Product ID:           \t%s"
msgstr "产品 ID:%s"

LOOKING FOR MSGID 'Product ID:' IN LANG FILE /usr/share/locale/zh_TW/LC_MESSAGES/rhsm.mo...
msgid "Product ID:           \t%s"
msgstr "產品 ID:           \t%s"



VERIFIED: ALL LANGS HAVE A TRANSLATION FOR "Product ID:".
OTHER BUGS HAVE BEEN OPENED FOR THE ABOVE TRANSLATIONS MISSING TAB CHARACTER "\t".
  bug 888891
  bug 888868
  bug 888858
Comment 10 errata-xmlrpc 2013-02-21 03:54:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.