This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 812510 - Need support for a shared 'meta' volume to store 'extra'-glusterd (clustering) information.
Need support for a shared 'meta' volume to store 'extra'-glusterd (clustering...
Status: CLOSED DEFERRED
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: krishnan parthasarathi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-14 03:34 EDT by krishnan parthasarathi
Modified: 2015-11-03 18:04 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-27 05:22:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description krishnan parthasarathi 2012-04-14 03:34:18 EDT
Description of problem:
Glusterd doesn't have means of creating a volume exclusively for storing information that may be used in maintaining the cluster outside the scope of glusterd.

Motivation:
This feature is brought in to facilitate clustering solutions like CTDB to be used in conjunction glusterd.

Version-Release number of selected component (if applicable):


How reproducible:
N/A

Steps to Reproduce:
1. N/A
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeff Darcy 2012-04-15 13:32:48 EDT
Creating a special kind of automatically created volume seems like a pretty significant change, and since it's only for such a specific purpose I think there needs to be a lot more discussion about requirements and alternatives.  How *exactly* would CTDB use this, what characteristics must it have, why can't CTDB use a standard manually created volume, how else might CTDB solve those problems, and what other things might benefit from this feature if it were defined a bit differently?
Comment 2 Amar Tumballi 2012-04-27 05:22:22 EDT
Currently we are planning to fix the issue by having the proper hooks itself, instead of creating a 'meta' volume.

Note You need to log in before you can comment on or make changes to this bug.