Bug 812514 - Unable to install quick-start application: myshoppinglist
Unable to install quick-start application: myshoppinglist
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Dan McPherson
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-14 05:32 EDT by Attila Nagy
Modified: 2015-05-14 21:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-27 16:46:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Attila Nagy 2012-04-14 05:32:03 EDT
Description of problem: I'm unable to use and install a quick-start example applicaion (myshoppinglist) which was uploaded to openshift repository on GitHub. Git pull operation returns error.  
URL: https://github.com/openshift/openshift-myshoppinglist

warning: no common commits
From git://github.com/openshift/openshift-myshoppinglist
 * branch            master     -> FETCH_HEAD
Auto-merging .gitignore
Auto-merging .openshift/action_hooks/build
CONFLICT (add/add): Merge conflict in .openshift/action_hooks/build
Auto-merging .openshift/action_hooks/deploy
CONFLICT (add/add): Merge conflict in .openshift/action_hooks/deploy
Auto-merging .openshift/action_hooks/post_deploy
CONFLICT (add/add): Merge conflict in .openshift/action_hooks/post_deploy
Auto-merging .openshift/action_hooks/pre_build
CONFLICT (add/add): Merge conflict in .openshift/action_hooks/pre_build
Auto-merging .openshift/cron/weekly/chronograph
CONFLICT (add/add): Merge conflict in .openshift/cron/weekly/chronograph
Auto-merging README
Auto-merging setup.py
Auto-merging wsgi/application
Automatic merge failed; fix conflicts and then commit the result.


Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. rhc-create-app -a myshoppinglist -t python-2.6
2. rhc-ctl-app -a myshoppinglist -e add-mongodb-2.0
3. cd myshoppinglist
4. git remote add upstream -m master git://github.com/openshift/openshift-myshoppinglist.git
5. git pull -s recursive -X theirs upstream master
  
Actual results: Git returns error (See above)


Expected results: Git pull operation must be successfull


Additional info:
Comment 1 Clayton Coleman 2012-04-14 13:40:53 EDT
This looks like your repository is messed up (your local one).  Before you created the shopping list was there a git repository at the relative folder "myshoppinglist"?
Comment 2 Attila Nagy 2012-04-16 04:53:01 EDT
There was no directory like 'myshoppinglist'. The local working copy is the one which was cloned just after the application was created with 'rhc app create'.
Comment 3 Dan McPherson 2012-04-16 11:32:30 EDT
Fixed in github
Comment 4 Attila Nagy 2012-04-17 04:14:55 EDT
Fix is verified

Note You need to log in before you can comment on or make changes to this bug.