Bug 812652 - unable to start shotwell
unable to start shotwell
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: shotwell (Show other bugs)
17
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Kalev Lember
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-15 14:33 EDT by Heiko Adams
Modified: 2012-05-04 18:55 EDT (History)
6 users (show)

See Also:
Fixed In Version: shotwell-0.12.2-2.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-04 18:55:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heiko Adams 2012-04-15 14:33:38 EDT
Description of problem:
Everytime i try to start shotwell the following error message is raise:

Error loading UI file /bin/ui/tag_sidebar_context.ui: Datei »/bin/ui/tag_sidebar_context.ui« konnte nicht geöffnet werden: Datei oder Verzeichnis nicht gefunden

Version-Release number of selected component (if applicable):
shotwell-0.12.2-1.fc17.x86_64

How reproducible:
allways

Steps to Reproduce:
1. install shotwell
2. start shotwell
3.
  
Actual results:
Shotwell doesn't start and the described error message is raised

Expected results:
Shotwell should start as expected

Additional info:
Comment 1 Matthias Clasen 2012-04-19 21:52:35 EDT
Does /usr/share/shotwell exist on your system ?
Comment 2 Heiko Adams 2012-04-20 15:14:01 EDT
Yes, its there:
$ ls -lh /usr/share/shotwell
insgesamt 8,0K
drwxr-xr-x. 2 root root 4,0K 15. Apr 20:27 icons
drwxr-xr-x. 2 root root 4,0K 15. Apr 20:27 ui

$ ls -lh /usr/share/shotwell/ui/
insgesamt 156K
-rw-r--r--. 1 root root 2,1K 13. Apr 13:36 collection.ui
-rw-r--r--. 1 root root  314 13. Apr 13:36 direct_context.ui
-rw-r--r--. 1 root root 2,9K 13. Apr 13:36 direct.ui
-rw-r--r--. 1 root root 2,4K 13. Apr 13:36 events_directory.ui
-rw-r--r--. 1 root root  604 13. Apr 13:36 event.ui
-rw-r--r--. 1 root root   86 13. Apr 13:36 fullscreen.ui
-rw-r--r--. 1 root root 1,3K 13. Apr 13:36 import_queue.ui
-rw-r--r--. 1 root root 3,1K 13. Apr 13:36 import.ui
-rw-r--r--. 1 root root 6,0K 13. Apr 13:36 media.ui
-rw-r--r--. 1 root root 3,2K 13. Apr 13:36 offline.ui
-rw-r--r--. 1 root root 1,6K 13. Apr 13:36 photo_context.ui
-rw-r--r--. 1 root root 5,7K 13. Apr 13:36 photo.ui
-rw-r--r--. 1 root root  268 13. Apr 13:36 savedsearch.ui
-rw-r--r--. 1 root root  763 13. Apr 13:36 search_bar.ui
-rw-r--r--. 1 root root  132 13. Apr 13:36 search_sidebar_context.ui
-rw-r--r--. 1 root root 5,0K 13. Apr 13:36 set_background_dialog.glade
-rw-r--r--. 1 root root  54K 13. Apr 13:36 shotwell.glade
-rw-r--r--. 1 root root  451 13. Apr 13:36 shotwell.xml
-rw-r--r--. 1 root root  190 13. Apr 13:36 sidebar_default_context.ui
-rw-r--r--. 1 root root  123 13. Apr 13:36 tag_sidebar_context.ui
-rw-r--r--. 1 root root  865 13. Apr 13:36 tags.ui
-rw-r--r--. 1 root root  475 13. Apr 13:36 top.ui
-rw-r--r--. 1 root root 3,8K 13. Apr 13:36 trash.ui
Comment 3 Heiko Adams 2012-04-27 16:08:47 EDT
any progress? shotwell still doesn't start
Comment 4 hannes 2012-04-28 10:12:16 EDT
Just a me too.
Comment 5 Kalev Lember 2012-05-02 04:24:34 EDT
What's your PATH env variable set to?

Does shotwell start correctly if you type out the full path on the command line:
'/usr/bin/shotwell'

and fail if started with
'/bin/shotwell'
and
'shotwell'
?
Comment 6 Kalev Lember 2012-05-02 05:16:43 EDT
Filed a ticket upstream: http://redmine.yorba.org/issues/5181

In the mean time, I've done a downstream patch to work around this issue:
http://pkgs.fedoraproject.org/gitweb/?p=shotwell.git;a=blob;f=shotwell-usrmove.patch;h=3661222990235f7b23eb08d6f5a7d092e8b5721b;hb=6436f3ef0ca4249a99a37eef5ae7f05a3a667ebb

Updated packages following shortly.
Comment 7 Fedora Update System 2012-05-02 05:19:04 EDT
shotwell-0.12.2-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/shotwell-0.12.2-2.fc17
Comment 8 Fedora Update System 2012-05-02 16:33:54 EDT
Package shotwell-0.12.2-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing shotwell-0.12.2-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7099/shotwell-0.12.2-2.fc17
then log in and leave karma (feedback).
Comment 9 Heiko Adams 2012-05-02 16:42:54 EDT
Looks like problem is fixed. Shotwell starts :-)
Comment 10 Heiko Adams 2012-05-02 16:43:33 EDT
Looks like problem is fixed. Shotwell starts :-)
Comment 11 Fedora Update System 2012-05-04 18:55:23 EDT
shotwell-0.12.2-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.