Bug 812729 - The volume name is different from the device name
The volume name is different from the device name
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-16 02:11 EDT by Xiaowei Li
Modified: 2015-01-26 19:10 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-16 03:04:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Xiaowei Li 2012-04-16 02:11:03 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.# lvcreate -l 254 -T vg3/pool-01
2.# ls -l /dev/mapper/vg3*
lrwxrwxrwx. 1 root root 8 Apr 16 02:05 /dev/mapper/vg3-pool--01 -> ../dm-45
lrwxrwxrwx. 1 root root 8 Apr 16 02:05 /dev/mapper/vg3-pool--01_tdata -> ../dm-43
lrwxrwxrwx. 1 root root 8 Apr 16 02:05 /dev/mapper/vg3-pool--01_tmeta -> ../dm-42
lrwxrwxrwx. 1 root root 8 Apr 16 02:05 /dev/mapper/vg3-pool--01-tpool -> ../dm-44

3.# lvs vg3
  LV      VG   Attr     LSize    Pool Origin Data%  Move Log Copy%  Convert
  pool-01 vg3  twi-a-tz 1016.00m               0.00    
  
Actual results:
/dev/mapper/vg3-pool--01


Expected results:
/dev/mapper/vg3-pool-01


Additional info:
Comment 1 Xiaowei Li 2012-04-16 02:12:31 EDT
this issue was encountered if the lv name has '-'
Comment 2 Peter Rajnoha 2012-04-16 03:04:59 EDT
This is not a bug. The '-' character is doubled if it's part of the volume name (or volume group name). The character is escaped this way because, otherwise, the '-' character alone is considered as a delimiter between a VG name and an LV name.
Comment 3 Alasdair Kergon 2012-04-16 11:19:39 EDT
The supported form for other software to use is '/dev/vg3/pool-01'.

/dev/mapper/* and /dev/dm-* are considered private internal names.
Comment 4 Alasdair Kergon 2012-04-16 11:21:46 EDT
(And in the case of thin pools, they will usually be considered private and not meant to be used by other software, so not available under /dev/vg*.)

Note You need to log in before you can comment on or make changes to this bug.