Bug 812741 - The target OS boot failed after converted citrix pv rhel5.8 i386 to libvirt/RHEVM by virt-p2v
The target OS boot failed after converted citrix pv rhel5.8 i386 to libvirt/R...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-p2v (Show other bugs)
6.3
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks: 840699 852650
  Show dependency treegraph
 
Reported: 2012-04-16 02:51 EDT by Cui Lei
Modified: 2015-03-12 13:32 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 852650 (view as bug list)
Environment:
Last Closed: 2015-03-12 13:32:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
issue picture (137.25 KB, image/png)
2012-04-16 02:51 EDT, Cui Lei
no flags Details
virt-p2v-server log (471.83 KB, text/x-log)
2012-04-16 02:53 EDT, Cui Lei
no flags Details

  None (edit)
Description Cui Lei 2012-04-16 02:51:35 EDT
Created attachment 577644 [details]
issue picture

Description of problem:
After converted citrix pv rhel5.8 i386 to libvirt/RHEVM by virt-p2v, the target OS boot failed. Which hang at the booting page, detail please refer to attached picture.
Also relevant p2v log have been attached.

Version-Release number of selected component (if applicable):
virt-p2v-0.8.6-2.iso
virt-v2v-0.8.7-4.el6.x86_64
libvirt-0.9.10-10.el6.x86_64
libguestfs-1.16.15-1.el6
augeas-libs-0.9.0-2.el6.x86_64
febootstrap-supermin-helper-3.12-1.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. install pv rhel5.8 i386 guest in citrix with URL installation
2. convert citrix pv rhel5.8 i386 to libvirt/RHEVM by virt-p2v
3. start the new converted target PV guest
  
Actual results:
The target OS boot failed

Expected results:
The target OS should boot successfully

Additional info:
Comment 2 Cui Lei 2012-04-16 02:53:58 EDT
Created attachment 577645 [details]
virt-p2v-server log
Comment 3 Cui Lei 2012-04-27 03:12:00 EDT
Converted citrix pv rhel5.8 x86_64 still met the same issue.
Comment 4 RHEL Product and Program Management 2012-05-03 01:05:03 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 5 Matthew Booth 2012-10-24 05:03:10 EDT
This is fixed upstream, but is targetted at RHEL 7.0. This feature isn't going to make it to RHEL 6.4.
Comment 6 RHEL Product and Program Management 2012-12-14 02:32:51 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 8 luxin 2013-08-15 02:45:21 EDT
This bug can be reproduced in other situations.

Description of problem:
After converted citrix pv rhel5.8,rhel4.8 and rhel4.9 to libvirt/RHEVM by virt-p2v, the target OS boot failed. 

In different version combinations can reproduce it:
virt-p2v-0.8.6-5.20120604.el6.iso
virt-v2v-0.8.7-6.el6.x86_64
libvirt-0.10.2-18.el6.x86_64
libguestfs-1.16.34-2.el6.x86_64
augeas-0.9.0-4.el6.x86_64
febootstrap-supermin-helper-3.12-2.el6.x86_64

virt-p2v-0.9.1-2.20130730.1.el6.iso
virt-v2v-0.8.7-6.el6.x86_64
libvirt-0.10.2-18.el6.x86_64
libguestfs-1.16.34-2.el6.x86_64
augeas-0.9.0-4.el6.x86_64
febootstrap-supermin-helper-3.12-2.el6.x86_64

virt-p2v-0.8.6-5.20120604.el6.iso
virt-v2v-0.9.1-1.el6_5.x86_64
libvirt-0.10.2-21.el6.x86_64
libguestfs-1.20.10-1.el6.x86_64
augeas-1.0.0-5.el6.x86_64
febootstrap-supermin-helper-3.21-4.el6.x86_64

and 
virt-p2v-0.9.1-2.20130730.1.el6.iso
virt-v2v-0.9.1-1.el6_5.x86_64
libvirt-0.10.2-21.el6.x86_64
libguestfs-1.20.10-1.el6.x86_64
augeas-1.0.0-5.el6.x86_64
febootstrap-supermin-helper-3.21-4.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. install pv rhel5.8 i386 guest in citrix with URL installation
2. convert citrix pv rhel5.8 i386 to libvirt/RHEVM by virt-p2v
3. start the new converted target PV guest
  
Actual results:
The target OS boot failed

Expected results:
The target OS should boot successfully
Comment 14 Richard W.M. Jones 2015-03-12 13:32:59 EDT
I'm closing this bug:

 - virt-p2v has been rewritten for RHEL 7.2

 - Unofficial previews of the new version are available:
   http://oirase.annexia.org/virt-p2v/

 - If a similar bug occurs with the new version of virt-p2v,
   please open a new bug against Red Hat Enterprise Linux 7 / libguestfs

Note You need to log in before you can comment on or make changes to this bug.