Bug 81280 - Rescue disk lacks e2fsck and rpm
Rescue disk lacks e2fsck and rpm
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2003-01-07 10:28 EST by Michael Young
Modified: 2007-04-18 12:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-16 19:36:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Young 2003-01-07 10:28:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0.1) Gecko/20020921
Netscape/7.0

Description of problem:
I have noticed a couple of important omissions in the rescue disk of
applications that seem essential to me if you are trying to rescue a system,
namely e2fsck and rpm.

Steps to Reproduce:
1.boot linux rescue
2. Look for e2fsck or rpm.
Comment 1 Jeremy Katz 2003-01-08 13:05:50 EST
Umm... they're both there.  They're just not in /bin or /sbin like they are on a
normal system but they're in your path.
Comment 2 Michael Young 2003-01-08 14:29:45 EST
Are you sure about that? I am sure I tried running at least one of them and got
command not found.
Comment 3 Michael Young 2003-01-08 15:28:38 EST
I have done more checking and the same is true of 8.0 as well! In case it
matters, I am booting off an install floppy, and using the ISO image on a hard
drive, and skipping the mount of the operating system. I get the following
# rpm
rpm: not found
similarly for fsck and e2fsck.
Comment 4 Jeremy Katz 2003-01-10 00:38:20 EST
Added e2fsck.  rpm is too large since it's statically linked and we're already
pushing that image a little larger than I'd like (every meg for the image is
another meg of RAM overhead for the installation)
Comment 5 Mike McLean 2003-01-16 19:36:53 EST
confirmed.  e2fsck is available.

rpm is only available when using nfs or cd rescue mode.

Note You need to log in before you can comment on or make changes to this bug.