Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 812834 - Subscription-manager not able to filter SLA for candlepin type consumer.
Summary: Subscription-manager not able to filter SLA for candlepin type consumer.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager
Version: 5.9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: William Poteat
QA Contact: IDM QE LIST
URL:
Whiteboard:
Depends On:
Blocks: 771748
TreeView+ depends on / blocked
 
Reported: 2012-04-16 11:48 UTC by spandey
Modified: 2015-04-23 23:57 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-24 16:17:30 UTC
Target Upstream Version:


Attachments (Terms of Use)
error screenshot (109.30 KB, image/png)
2012-04-16 11:50 UTC, spandey
no flags Details

Description spandey 2012-04-16 11:48:45 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
3/3

Prerequisites:
Rhel6.3 with following subscription-manager rpm 
subscription-manager-0.99.14-1.git.2.cf76d8e.el6_2.x86_64
subscription-manager-migration-data-1.12.1.3-1.git.0.1b05607.el6_2.noarch
subscription-manager-migration-0.99.14-1.git.2.cf76d8e.el6_2.x86_64
subscription-manager-gnome-0.99.14-1.git.2.cf76d8e.el6_2.x86_64
subscription-manager-firstboot-0.99.14-1.git.2.cf76d8e.el6_2.x86_64

Steps to Repro : 
Client with 37060.pem 
register client to candlepin using cnsumer type candlepin via cli (no autosubscribe) 
set SLA preference premium in gui  and press "autosubscribe" button. 

Expected REsult : 
It should display only premium SLA subscription to subscribe. 

Actual REsult : 
Autosubscribe subscribe Standard SLA subscription with preference Premium in gui . 

Attached error screenshot.

Comment 1 spandey 2012-04-16 11:50:41 UTC
Created attachment 577687 [details]
error screenshot

Comment 3 Devan Goodwin 2012-04-17 13:43:33 UTC
Because candlepin consumers are used to transfer subscriptions to downstream candlepin's via the manifest, they are exempt from JS rule checks so they can transfer anything.

Indeed this is where the SLA filtering happens, so that explains why Candlepin consumers are not seeing this.

However the use case of using subscription manager to register as a Candlepin consumer is not something any end user should actually do. (that functionality is purely for dev/QE purposes)

Similarly I don't think a Candlepin consumer with an SLA assigned to it is something that should actually be done either. (they also would never use autosubscribe)

As such I propose this is definitely not something to worry about for 6.3, it may not be something worth fixing at all, as I don't think there's an actual use case here.

Comment 4 Devan Goodwin 2012-04-17 13:48:48 UTC
Moving to 5.9.

Comment 5 RHEL Program Management 2012-04-17 14:07:15 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.

Comment 6 James Bowes 2012-05-24 16:17:30 UTC
As per comment 3 I'm going to close this as notabug.


Note You need to log in before you can comment on or make changes to this bug.