Bug 812873 - Thunderbird is unresponsive and virtually useless.
Thunderbird is unresponsive and virtually useless.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
11
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-16 09:12 EDT by ea6825
Modified: 2014-09-03 08:18 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-03 08:18:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Strace output (3.83 MB, application/octet-stream)
2012-04-16 13:36 EDT, ea6825
no flags Details
Thunderbird Command Line Output (174.30 KB, image/png)
2012-04-16 13:37 EDT, ea6825
no flags Details
Thunderbird Tools-extensions Screen Print (174.33 KB, image/png)
2012-04-16 13:38 EDT, ea6825
no flags Details
Thunderbird Plugins Screen Print (page 1) (226.16 KB, image/png)
2012-04-16 13:39 EDT, ea6825
no flags Details
Thunderbird Plugins Screen Print (page 2) (225.76 KB, image/png)
2012-04-16 13:40 EDT, ea6825
no flags Details
Thunderbird Plugins Screen Print (page 3) (223.79 KB, image/png)
2012-04-16 13:41 EDT, ea6825
no flags Details
Thunderbird Plugins Screen Print (page 4, final page) (228.50 KB, image/png)
2012-04-16 13:42 EDT, ea6825
no flags Details

  None (edit)
Description ea6825 2012-04-16 09:12:14 EDT
Description of problem: Thunderbird no longer displays email that is selected when clicked upon from the list of email messages displayed 


Version-Release number of selected component (if applicable):  11


How reproducible: Start Thunderbird to view messages


Steps to Reproduce:
1.  Start Thunderbird
2.  Try to select an email message to view it
3.  Thunderbird does not respond
  
Actual results:  Message displayed remains to be the previous message viewed not the new one selected from the list of email messages in a folder.


Expected results:  View the email message that is currently selected or clicked upon


Additional info:  Thunderbird is virtually unresponsive.  It used to be a good product but this renders it nearly useless.  It is a shame.
Comment 1 Jan Horak 2012-04-16 10:26:04 EDT
This might be related to some extensions or plugins. Please attach following info to bug report:

https://fedoraproject.org/wiki/Debugging_guidelines_for_Mozilla_products#Reporting_addons_and_plugins_issues

Please be sure you're using latest thunderbird package. There were some issues with thunderbird-11.0-1 package. Latest should be thunderbird-11.0.1-1.
Comment 2 ea6825 2012-04-16 13:36:28 EDT
Created attachment 577785 [details]
Strace output
Comment 3 ea6825 2012-04-16 13:37:45 EDT
Created attachment 577786 [details]
Thunderbird Command Line Output
Comment 4 ea6825 2012-04-16 13:38:43 EDT
Created attachment 577787 [details]
Thunderbird Tools-extensions Screen Print
Comment 5 ea6825 2012-04-16 13:39:50 EDT
Created attachment 577790 [details]
Thunderbird Plugins Screen Print (page 1)
Comment 6 ea6825 2012-04-16 13:40:48 EDT
Created attachment 577791 [details]
Thunderbird Plugins Screen Print (page 2)
Comment 7 ea6825 2012-04-16 13:41:32 EDT
Created attachment 577794 [details]
Thunderbird Plugins Screen Print (page 3)
Comment 8 ea6825 2012-04-16 13:42:47 EDT
Created attachment 577795 [details]
Thunderbird Plugins Screen Print (page 4, final page)
Comment 9 ea6825 2012-04-16 13:48:44 EDT
This problem is 'spawned' from Thunderbird 11.0-1.  This is the current version in distribution from FC16.  If Thunderbird 11.0.1-1 resolves this difficulty, it goes without saying I am keenly interested about when this new & improved version will be in distribution.
Comment 10 ea6825 2012-04-16 13:51:02 EDT
This problem is 'spawned' from Thunderbird 11.0-1.  This is the current version in distribution from FC16.  If Thunderbird 11.0.1-1 resolves this difficulty, it goes without saying I am keenly interested about when this new & improved version will be in distribution.
Comment 11 ea6825 2012-04-16 14:04:46 EDT
After my previous comment I find something confusing.  You be the judge.  When I view the 'help' page from Thunderbirds main menu it shows 11.0.1 but when I look at my package manager, I see that it shows 11.0.1-1 is installed.  ????
Comment 12 Jan Horak 2012-04-17 06:26:02 EDT
The 11.0.1 addressed an issue which could hang when using IMAP folders (see http://www.mozilla.org/en-US/thunderbird/11.0.1/releasenotes/ ). So updating to 11.0.1 could solve your issue too.

We've had an error in guidelines which is fixed now. I just need output of:
rpm -q thunderbird

Sorry for this confusion, debugging guidelines has been created recently and we find some errors in it from time to time. It's fixed now.

According to your last message it seems that you have 11.0.1 installed (but please recheck by 'rpm -q thunderbird' command). In this case if I get it correctly you're experiencing UI freeze (application is totally unresponsive for longer time) when clicking to another mail. If that's your case I'd like to kindly ask you to follow these steps: 
https://fedoraproject.org/wiki/Debugging_guidelines_for_Mozilla_products#Application_freeze

Attach debugger to running application just in the moment freeze occurs.
Thanks.
Comment 13 H. Peter Anvin, Intel 2012-04-25 13:29:57 EDT
I am seeing this as well.  I have lots of mails -- several million email messages across hundreds of IMAP folders -- but since Thunderbird 11 was pushed out I'm seeing freezes the like I haven't seen for years.

My current package is thunderbird-11.0.1-1.fc15.x86_64.

I will look at this as well.

One thing I can tell: the frozen process burns 100% CPU and an strace shows it searching through some kind of ASCII database.  This looks very familiar; this is the way Thunderbird used to hang in the days of yore.
Comment 14 Jan Horak 2012-05-03 05:38:02 EDT
Do you have thunderbird-lightning installed? I had problems with tb+lightning 11 freezes. It improved a lot with Thunderbird 12 and lightning 1.4.
You can find them here:
Fedora 15:
https://admin.fedoraproject.org/updates/FEDORA-2012-7149/thunderbird-12.0.1-1.fc15,thunderbird-lightning-1.4-2.fc15

Fedora 16:
https://admin.fedoraproject.org/updates/FEDORA-2012-7150/thunderbird-12.0.1-1.fc16,thunderbird-lightning-1.4-2.fc16

Please let us know if your problem has been fixed by update to 12.0.1 and 1.4.
Comment 15 ea6825 2012-05-03 10:17:14 EDT
I have installed thunderbird-12.0.1-1.fc16 at your suggestion.  rpm -q thunderbird command will only show this new install info.  I do not have this 'lightning' app installed so it can not have any affect on the problem.  I had previously reported a problem (810011) where I report a problem with thunderbird not deleting emails that you want deleted.  It may somehow relate to this bug as well.
Comment 16 ea6825 2012-05-07 12:12:17 EDT
After upgrade to thunderbird-12.0.1-1.fc16 I see that it also becomes unresponsive and has email deleting issues.
Comment 17 ea6825 2012-05-07 12:12:54 EDT
After upgrade to thunderbird-12.0.1-1.fc16 I see that it also becomes unresponsive and has email deleting issues.
Comment 18 Jan Horak 2012-05-09 07:22:37 EDT
(In reply to comment #13)
> I am seeing this as well.  I have lots of mails -- several million email
> messages across hundreds of IMAP folders -- but since Thunderbird 11 was pushed
> out I'm seeing freezes the like I haven't seen for years.
> 
> My current package is thunderbird-11.0.1-1.fc15.x86_64.
> 
> I will look at this as well.
> 
> One thing I can tell: the frozen process burns 100% CPU and an strace shows it
> searching through some kind of ASCII database.  This looks very familiar; this
> is the way Thunderbird used to hang in the days of yore.

If you still see this, please follow these instructions:
https://fedoraproject.org/wiki/Debugging_guidelines_for_Mozilla_products#Application_freeze
Run debugger when you encounter frozen UI and 100% CPU. This might be different bug. Thanks.
Comment 19 Jan Horak 2012-05-09 08:37:43 EDT
(In reply to comment #17)
> After upgrade to thunderbird-12.0.1-1.fc16 I see that it also becomes
> unresponsive and has email deleting issues.
Sorry for inconveniences. Do you have any special setup (like home on nfs)?
Please follow same instructions in comment 18 in case of freeze. Thanks.
Comment 20 Jan Horak 2012-08-10 09:42:48 EDT
Do you still see this problem?
Comment 21 Steven Ellis 2012-11-26 21:11:04 EST
Does this relate to https://bugzilla.redhat.com/show_bug.cgi?id=493000

Sounds similar.
Comment 22 Wayne Mery (:wsmwk) 2014-08-06 08:04:53 EDT
(In reply to Steven Ellis from comment #21)
> Does this relate to https://bugzilla.redhat.com/show_bug.cgi?id=493000
> 
> Sounds similar.

Perhaps. But I think it's often more helpful for people do diagnosis first and then file their own seperate bug report.  So I think we should leave that bug to the people who commented there long ago, and ditto for this bug report, and for today's issues ...

Please see https://wiki.mozilla.org/Thunderbird:Testing:Memory_Usage_Problems#Diagnosis_Steps (of course, ignore the MS-Windows related stuff), and file a new bug report accordingly.
Comment 23 Wayne Mery (:wsmwk) 2014-08-06 08:12:56 EDT
(In reply to Jan Horak from comment #19)
> (In reply to comment #17)
> > After upgrade to thunderbird-12.0.1-1.fc16 I see that it also becomes
> > unresponsive and has email deleting issues.
> Sorry for inconveniences. Do you have any special setup (like home on nfs)?
> Please follow same instructions in comment 18 in case of freeze. Thanks.

Jan, reporter wrote to me "I do not see this problem since I have found Thunderbird unusable and have not used it in over a year.   I hope someone fixed it since it used to be a very good product.  Too bad that inadequate testing occurs before software is slated for 'production'.   I am sorry I can't be more help."

So unless  you found something useful in the submitted attachments, I think this bug should be closed until reporter returns with an update.
Comment 24 Jan Horak 2014-09-03 08:18:21 EDT
Let's close it, if your problem reoccurs feel free to reopen the bug.

Note You need to log in before you can comment on or make changes to this bug.