Bug 812899 - By Environments view of systems shows all systems the first time
By Environments view of systems shows all systems the first time
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Partha Aji
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-16 09:59 EDT by Og Maciel
Modified: 2014-09-18 11:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In CloudForms System engine, the list of systems reported when selecting "Systems -> By Environment" is not correct when the page loads for the first time. System Engine will display *all* available systems on the first page load. However, when selecting different environments, the correct list of systems will be displayed. This issue will be resolved in a future CloudForms System Engine release.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 13:38:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (63.88 KB, image/png)
2012-04-16 09:59 EDT, Og Maciel
no flags Details

  None (edit)
Description Og Maciel 2012-04-16 09:59:42 EDT
Created attachment 577721 [details]
Screenshot

Description of problem:

The first time you select the By Environments tab in the Systems' tab, all systems are displayed by default though they not all belong to the selected ENV. The attached screenshot shows that even though Dev1 environment is selected, all registered systems are shown.

If you click on a different ENV and then go back to the original one, then you get the correct behavior of displaying only the systems registered against that environment.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Register a couple of different systems making sure to use different environments
2. Click the Systems tab
3. Click the By Environments sub tab
  
Actual results:

All systems are being displayed.
Expected results:


Additional info:

The default view does not pass the env_id and so fetches everything.

GET https://qetello02.usersys.redhat.com/katello/systems/items?_=1334583677145

{"total_items":3,"results_count":3,"current_items":3,"html":"<div class='block tall' data-ajax_url='/katello/systems/1/edit' id='system_1'>\n<div>\n<div class='column_2'>\n<div class='product'>\n<div class='green status_icon'></div>\n</div>\n<div class='one-line-ellipsis' id='heading_title' style='padding-top: 2px;'>\nqeclient01.usersys.redhat.com\n</div>\n</div>\n<div class='column_2'>\nMon, 16 Apr 2012 09:24:11 -0400\n</div>\n</div>\n<div>\n<div class='column_1'>\n<ul>\n<li>\n&nbsp;&nbsp;\nOS: \nRed Hat Enterprise Linux Server\n&nbsp;&nbsp;\nx86_64\n</li>\n<li>\n&nbsp;&nbsp;\nIP: \n10.16.79.178\n</li>\n</ul>\n</div>\n</div>\n<div class='arrow-right'></div>\n\n</div>\n<div class='block tall' data-ajax_url='/katello/systems/2/edit' id='system_2'>\n<div>\n<div class='column_2'>\n<div class='product'>\n<div class='green status_icon'></div>\n</div>\n<div class='one-line-ellipsis' id='heading_title' style='padding-top: 2px;'>\nqeclient02.usersys.redhat.com\n</div>\n</div>\n<div class='column_2'>\nMon, 16 Apr 2012 09:24:12 -0400\n</div>\n</div>\n<div>\n<div class='column_1'>\n<ul>\n<li>\n&nbsp;&nbsp;\nOS: \nRed Hat Enterprise Linux Server\n&nbsp;&nbsp;\nx86_64\n</li>\n<li>\n&nbsp;&nbsp;\nIP: \n10.16.79.170\n</li>\n</ul>\n</div>\n</div>\n<div class='arrow-right'></div>\n\n</div>\n<div class='block tall' data-ajax_url='/katello/systems/3/edit' id='system_3'>\n<div>\n<div class='column_2'>\n<div class='product'>\n<div class='green status_icon'></div>\n</div>\n<div class='one-line-ellipsis' id='heading_title' style='padding-top: 2px;'>\nqeclient03.usersys.redhat.com\n</div>\n</div>\n<div class='column_2'>\nMon, 16 Apr 2012 09:24:12 -0400\n</div>\n</div>\n<div>\n<div class='column_1'>\n<ul>\n<li>\n&nbsp;&nbsp;\nOS: \nRed Hat Enterprise Linux Server\n&nbsp;&nbsp;\nx86_64\n</li>\n<li>\n&nbsp;&nbsp;\nIP: \n10.16.79.202\n</li>\n</ul>\n</div>\n</div>\n<div class='arrow-right'></div>\n\n</div>\n\n"}

Should have been:

GET https://qetello02.usersys.redhat.com/katello/systems/items?env_id=5&_=1334583677350

{"html":"<div class='block tall' data-ajax_url='/katello/systems/1/edit' id='system_1'>\n<div>\n<div class='column_2'>\n<div class='product'>\n<div class='green status_icon'></div>\n</div>\n<div class='one-line-ellipsis' id='heading_title' style='padding-top: 2px;'>\nqeclient01.usersys.redhat.com\n</div>\n</div>\n<div class='column_2'>\nMon, 16 Apr 2012 09:24:11 -0400\n</div>\n</div>\n<div>\n<div class='column_1'>\n<ul>\n<li>\n&nbsp;&nbsp;\nOS: \nRed Hat Enterprise Linux Server\n&nbsp;&nbsp;\nx86_64\n</li>\n<li>\n&nbsp;&nbsp;\nIP: \n10.16.79.178\n</li>\n</ul>\n</div>\n</div>\n<div class='arrow-right'></div>\n\n</div>\n\n","results_count":1,"current_items":1,"total_items":1}
Comment 3 James Laska 2012-04-18 11:44:23 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
In CloudForms System engine, the list of systems reported when selecting "Systems -> By Environment" is not correct when the page loads for the first time.  System Engine will display *all* available systems on the first page load.  However, when selecting different environments, the correct list of systems will be displayed.

This issue will be resolved in a future CloudForms System Engine release.
Comment 6 Mike McCune 2014-03-18 13:38:58 EDT
This bug was closed because of a lack of activity.  If you feel this bug should be reconsidered for attention please feel free to re-open the bug with a comment stating why it should be reconsidered.

Note You need to log in before you can comment on or make changes to this bug.