Bug 812903 - Autosubscribe is not working for newly added product cert after Register .
Autosubscribe is not working for newly added product cert after Register .
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 5.9
Assigned To: Shwetha Kallesh
Entitlement Bugs
: Reopened
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-04-16 10:14 EDT by spandey
Modified: 2015-04-23 19:57 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:51:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhsm.log (414.54 KB, text/x-log)
2012-04-16 10:17 EDT, spandey
no flags Details
not autosubscribing with 37060.pem (65.22 KB, image/png)
2012-04-16 10:18 EDT, spandey
no flags Details
auto-subscribing after adding the product (79.06 KB, image/png)
2012-08-22 06:04 EDT, Shwetha Kallesh
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0033 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2013-01-08 03:38:27 EST

  None (edit)
Description spandey 2012-04-16 10:14:40 EDT
Description of problem:


Prerequisites : 
Product cert : 37060.pem 
subscription-manager-0.99.14-1.git.2.cf76d8e.el6_2.x86_64
subscription-manager-migration-data-1.12.1.3-1.git.0.1b05607.el6_2.noarch
subscription-manager-migration-0.99.14-1.git.2.cf76d8e.el6_2.x86_64
subscription-manager-gnome-0.99.14-1.git.2.cf76d8e.el6_2.x86_64
subscription-manager-firstboot-0.99.14-1.git.2.cf76d8e.el6_2.x86_64


Steps to Repro: 
Delete every product form /etc/pki/product/
Register client to candlepin .
Add 37060.pem cert to “/etc/pki/product” location.
Select Premium for SLA preference in GUI.
Press Autosubscribe button .

Expected Result : 
SLA Box should open with matched SLA subscription .

Actual Result :
Got message to manual subscribe subscription.  

Attached rhsm.log and screenshot
Comment 1 spandey 2012-04-16 10:17:08 EDT
Created attachment 577725 [details]
rhsm.log
Comment 2 spandey 2012-04-16 10:18:18 EDT
Created attachment 577726 [details]
not autosubscribing with 37060.pem
Comment 4 Devan Goodwin 2012-04-17 12:10:21 EDT
Installed products are sent during registration and refreshed if necessary when the rhsmcertd runs. By registering, then manually adding a new installed product cert, if the daemon hasn't yet run, the server doesn't know that product is installed. 

Normally the product certs are there when registering, suspect this issue is low priority so proposing we postpone until 6.4.
Comment 5 Chris Duryee 2012-04-23 10:14:28 EDT
Moving to 5.9 per mstead
Comment 6 RHEL Product and Program Management 2012-04-23 10:27:26 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 7 William Poteat 2012-08-14 13:07:48 EDT
master commit baa28074474b06e0f931c7cd1b250faa72d8259e
Comment 8 Shwetha Kallesh 2012-08-22 06:04:37 EDT
Created attachment 606187 [details]
auto-subscribing after adding the product

Marking verified

[root@dhcp201-196 ~]# rpm -qa | grep subscription-manager
subscription-manager-gui-1.0.14-1.git.10.4cd750a.el5
subscription-manager-migration-1.0.14-1.git.10.4cd750a.el5
subscription-manager-migration-data-1.11.2.3-1.git.0.861f9ba.el5
subscription-manager-firstboot-1.0.14-1.git.10.4cd750a.el5
subscription-manager-1.0.14-1.git.10.4cd750a.el5
Comment 10 errata-xmlrpc 2013-01-07 22:51:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.