Bug 812943 - pilot-link utilities can't communicate with Palm on usb:
pilot-link utilities can't communicate with Palm on usb:
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pilot-link (Show other bugs)
15
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Schiffer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-16 12:05 EDT by Sean Sheedy
Modified: 2012-06-04 06:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-01 12:59:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of "pilot-dlpsh -p usb: -c user" (185.18 KB, text/plain)
2012-04-16 12:05 EDT, Sean Sheedy
no flags Details

  None (edit)
Description Sean Sheedy 2012-04-16 12:05:11 EDT
Created attachment 577750 [details]
strace of "pilot-dlpsh -p usb: -c user"

Description of problem:
pilot-link utilities can no longer communicate with my Palm Centro via the usb: device.

Version-Release number of selected component (if applicable):
0.12.5-5

How reproducible:
Always

Steps to Reproduce:
1. Attempt to connect to Palm Centro via usb: with any pilot-link utility.
2. Push sync button on Palm.
  
Actual results:
A connection is seen from the usb device, but a timeout occurs reading the data.

Additional info:

A sample run of the pilot-dlpsh utility:


% pilot-dlpsh -p usb: -c user

   Listening for incoming connection on usb:... connected!


   Error read system info on usb:
Comment 1 Alex Lancaster 2012-04-16 18:36:03 EDT
My comment in bug 449968 comment 36 applies here too:  This may just be broken upstream (i.e. in pilot-link itself), and since upstream is more or less dormant and no new PalmOS 5.x devices are in production any longer, so I suspect that this bug may never be fixed, except by somebody willing to debug it right down to the device level (which is well beyond me as packager).  Although I hope I'm wrong: perhaps the new maintainer, Peter Schiffer, may have some ideas (I've ceased using my old Palm Treo, so I'm not actively doing any testing, so may eventually drop my co-maintainership).
Comment 2 Peter Schiffer 2012-06-01 12:59:23 EDT
Sean,

I tried to reproduce this with different phone, but with no luck.

I am going to close this bug as CANTFIX, based on Alex's comment. The upstream is gone and this kind of HW is getting old.

peter
Comment 3 Sean Sheedy 2012-06-01 19:52:09 EDT
I retried with the latest FC15 kernel (2.6.43.5-2) and this problem has gone away.
Comment 4 Peter Schiffer 2012-06-04 06:32:57 EDT
Thanks for update Sean. I am changing closed status to CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.